summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2019-01-31 11:02:01 -0700
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-11 14:42:57 -0600
commita9253961a21893cdbcd4249f2aba7741b39ceac4 (patch)
treeff8d0dca84d3c46404f1134ca50a38bebdea9254 /dev-python/bashate
parentdev-ruby/ruby-gdk3: add 3.3.2 (diff)
downloadgentoo-a9253961a21893cdbcd4249f2aba7741b39ceac4.tar.gz
gentoo-a9253961a21893cdbcd4249f2aba7741b39ceac4.tar.bz2
gentoo-a9253961a21893cdbcd4249f2aba7741b39ceac4.zip
dev-python/bashate: Version bump to 0.6.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest1
-rw-r--r--dev-python/bashate/bashate-0.6.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
index e0d742a128f7..17847e9b9554 100644
--- a/dev-python/bashate/Manifest
+++ b/dev-python/bashate/Manifest
@@ -1 +1,2 @@
DIST bashate-0.3.1.tar.gz 16016 BLAKE2B 72bcb6ef2c8dda48b40351f37971473b9c2137f3a727a355f1742f20355aee8a3898d4aaf61e0e6538b22adbe3ebd34bb30d67d0fb6b5f3535c9b46c1544ce5d SHA512 dfa3e8f98879169cef445cc9a788b4ed051630330e2270c721e472f080899d6742cd3deb571049ba6b943ada0fc77a70f5a7e4742a54d1ca6d5f075a92a00ffb
+DIST bashate-0.6.0.tar.gz 30980 BLAKE2B 5b210edaa44a0652a03f30a641a072dba1482e1ca3b42c6b7140a52349ddb271f0137373a4d2f364032c22c176d6caf14be2635038df8a4e86585773d17a1f97 SHA512 bb64d8de0143bf2662497b1571ce654f4ceeb7d1dea3f625705b609ab70ed3b4bca6266c4eba7c2e7d99a1520fb9566a4a4daefa34c9c16538537b446c1da255
diff --git a/dev-python/bashate/bashate-0.6.0.ebuild b/dev-python/bashate/bashate-0.6.0.ebuild
new file mode 100644
index 000000000000..3348f8aac55d
--- /dev/null
+++ b/dev-python/bashate/bashate-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+DISTUTILS_IN_SOURCE_BUILD=TRUE
+
+# time
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+"
+RDEPEND="
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-pythn/Babel-2.4.0
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}