summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-09 06:18:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-09 06:18:35 +0100
commit2d4dba474ba6fea2293fcce0c7b7fe896bd119ca (patch)
treefa13bd26409dc1ca7d34638691e7e7745b58ac44 /dev-python/aiofiles
parentdev-python/packaging: Add a blocker on old setuptools (diff)
downloadgentoo-2d4dba474ba6fea2293fcce0c7b7fe896bd119ca.tar.gz
gentoo-2d4dba474ba6fea2293fcce0c7b7fe896bd119ca.tar.bz2
gentoo-2d4dba474ba6fea2293fcce0c7b7fe896bd119ca.zip
dev-python/aiofiles: Bump to 23.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-23.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index 99b89fc71989..7f579a41086b 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-22.1.0.gh.tar.gz 21630 BLAKE2B 8f068046fc143388debc93b657f8b4715cd48eac7e7b8a031ccdc6d2f5764ddcafb2ad1fab713ca55366cad951b570e1c2a120932bf5545482e1a3f086a76bf9 SHA512 6706fb7b6fd32df415ece64f35b8ccc2f263301c43292612b2b6173fb66c77bc88fd08ed0b0bb30fa3dd49571be8fc733a3d4f3611228fdbb368743588336357
+DIST aiofiles-23.1.0.gh.tar.gz 30110 BLAKE2B c6cb0880cc761d3c34eefbda373a361a3f20bc6e37c81c769609b149dd13ff6cf9f169d63cbde9d02cd91a49d03198705576389c531a82fcd614e7b464bdafe8 SHA512 7afbc492061df6b5e76514d36938ec39e3261fbf0c3123d38f1d32cc1d335603d6ab681c088d9c68ef5be9fc9b9eec1b460268b03d5f6409213bf20ec87dde47
diff --git a/dev-python/aiofiles/aiofiles-23.1.0.ebuild b/dev-python/aiofiles/aiofiles-23.1.0.ebuild
new file mode 100644
index 000000000000..b8347ab03843
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-23.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+SRC_URI="
+ https://github.com/Tinche/aiofiles/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest