summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-10 08:35:51 +0000
committerSam James <sam@gentoo.org>2023-03-10 08:40:04 +0000
commit4618856e9b089601aefc7d4a231d1a9c5eb28524 (patch)
tree802209485aba455577afd77587c776c3fc612a5e /dev-python/PyQt-builder
parentdev-python/sip: add 6.7.7 (diff)
downloadgentoo-4618856e9b089601aefc7d4a231d1a9c5eb28524.tar.gz
gentoo-4618856e9b089601aefc7d4a231d1a9c5eb28524.tar.bz2
gentoo-4618856e9b089601aefc7d4a231d1a9c5eb28524.zip
dev-python/PyQt-builder: add 1.14.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/PyQt-builder')
-rw-r--r--dev-python/PyQt-builder/Manifest1
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.14.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/Manifest b/dev-python/PyQt-builder/Manifest
index 250b654500af..3ea0cb980312 100644
--- a/dev-python/PyQt-builder/Manifest
+++ b/dev-python/PyQt-builder/Manifest
@@ -1 +1,2 @@
DIST PyQt-builder-1.12.2.tar.gz 5727071 BLAKE2B ca5d55989fec2a9a6f9d37abc307d4db7305bb06449cbf982aa3a2a3f210113319f7fb303ec0d77b513cce844b529e0e56f62c9d62ab3c51cf85a061ecd00c7a SHA512 022f2cd40c100543c4b442fc5b27bbf2ec853d94b531f8f6dc1d7f92b07bcc20e8f0a4eb64feb96d094ba0d5f01fddcc8aed23ddf67a61417e07983a73918230
+DIST PyQt-builder-1.14.1.tar.gz 3907982 BLAKE2B f2ac51b6af3b90d14e1acea1c292f71df6b84e4a6b930b70762a29d58e34303d9788911c99127ff15b85b4f7f7ae699ed2aa3094b7f187aeb92338feaaaadfb0 SHA512 4de9be2c42f38fbc22d46a31dd6da37c02620bb112a674ef846a4eb7f862715852e1d7328da1e0d0e33f78475166fe3c690e710e18bfeb48f840f137831a2182
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.14.1.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.14.1.ebuild
new file mode 100644
index 000000000000..e6a4c96790ac
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.14.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_prepare_all() {
+ # don't install prebuilt Windows DLLs
+ sed -i -e "s:'dlls/\*/\*',::" setup.py || die
+ rm -r "${PN/-/_}.egg-info" || die
+
+ distutils-r1_python_prepare_all
+}