summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:14:26 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:14:26 +0100
commitc835d8e03ab9f3a806620a0f26f4a4565c6ccb90 (patch)
treef737e03fafaf568541adbba76aa9268679eaa1ed /dev-php/pecl-rrd
parentdev-php/pecl-translit: add PHP 7.4 support (diff)
downloadgentoo-c835d8e03ab9f3a806620a0f26f4a4565c6ccb90.tar.gz
gentoo-c835d8e03ab9f3a806620a0f26f4a4565c6ccb90.tar.bz2
gentoo-c835d8e03ab9f3a806620a0f26f4a4565c6ccb90.zip
dev-php/pecl-rrd: add PHP 7.4 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-rrd')
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
index 19278bc6f6d8..16e4bc484026 100644
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r3.ebuild
@@ -4,12 +4,12 @@
EAPI="7"
# Define 5.6 here to have the {I,REQUIRED_}USE generated
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
# But we really only build 7.0
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
DESCRIPTION="RRDtool bindings for PHP"
LICENSE="BSD"
@@ -20,11 +20,12 @@ DEPEND="
php_targets_php7-1? ( net-analyzer/rrdtool[graph] )
php_targets_php7-2? ( net-analyzer/rrdtool[graph] )
php_targets_php7-3? ( net-analyzer/rrdtool[graph] )
+ php_targets_php7-4? ( net-analyzer/rrdtool[graph] )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"
src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default
@@ -32,21 +33,21 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
local PHP_EXT_ECONF_ARGS=()
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}
src_test() {
local slot
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-3 || use php_targets_php7-4 ; then
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
# Prepare test data