summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-gnupg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-gnupg')
-rw-r--r--dev-php/pecl-gnupg/Manifest2
-rw-r--r--dev-php/pecl-gnupg/files/1.3.2/01-large_file_system.patch9
-rw-r--r--dev-php/pecl-gnupg/metadata.xml5
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.3.3.ebuild31
-rw-r--r--dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild31
5 files changed, 78 insertions, 0 deletions
diff --git a/dev-php/pecl-gnupg/Manifest b/dev-php/pecl-gnupg/Manifest
new file mode 100644
index 000000000000..8823a52888ab
--- /dev/null
+++ b/dev-php/pecl-gnupg/Manifest
@@ -0,0 +1,2 @@
+DIST gnupg-1.3.3.tgz 19141 SHA256 6a20b9bb8567b305a77bc2c5671c3cb28006f337f5f022aff4e2968a2a3eb121 SHA512 ac6c315e7734b9efc82aa18664572dc24977d285cae588e58f5dbe8c7caeb89216f4be3889d18fa9840c69ab201faee058d3e4cd197f977e60fcb0a4fd594ed2 WHIRLPOOL 9f798989856e67ea4792502840a2a33b0b09fc110a2122ed65cc0c7faec363704164dbfd25ded3c704149fe6cff81cb686df0531caf73b4c94cfd55127469d04
+DIST gnupg-1.3.6.tgz 19273 SHA256 50065cb81f1ac3ec5fcd796e58c8433071ff24cc14900e6077682717f5239307 SHA512 94061da44ab950571b38ea677e904eae1d099f8b6b528ade5e242ff1a67d81ac7e70174bc075037d7820e9cd7983524d67e1381d1ab2e98d466fe1e855820b73 WHIRLPOOL 1423ecbdd59607198a39ba51286d7e9380dfbdcfe9f70bdf932ef57b5cc863b92ef0a85409e40fb88499d628f80a800c90821f671727bd50d083a65a61c8bdc1
diff --git a/dev-php/pecl-gnupg/files/1.3.2/01-large_file_system.patch b/dev-php/pecl-gnupg/files/1.3.2/01-large_file_system.patch
new file mode 100644
index 000000000000..4e64e3ccef1a
--- /dev/null
+++ b/dev-php/pecl-gnupg/files/1.3.2/01-large_file_system.patch
@@ -0,0 +1,9 @@
+--- config.m4 2007-05-04 13:23:41.000000000 +0000
++++ config.m4.new 2010-03-28 01:13:10.000000000 +0000
+@@ -41,4 +41,6 @@
+ PHP_SUBST(GNUPG_SHARED_LIBADD)
+
+ PHP_NEW_EXTENSION(gnupg, [gnupg.c gnupg_keylistiterator.c], $ext_shared)
++
++ AC_SYS_LARGEFILE
+ fi
diff --git a/dev-php/pecl-gnupg/metadata.xml b/dev-php/pecl-gnupg/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/pecl-gnupg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.3.3.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.3.3.ebuild
new file mode 100644
index 000000000000..4e1d0a283e7d
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/1.3.2/01-large_file_system.patch
+ done
+
+ php-ext-source-r2_src_prepare
+}
diff --git a/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild b/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild
new file mode 100644
index 000000000000..4b2e7109a584
--- /dev/null
+++ b/dev-php/pecl-gnupg/pecl-gnupg-1.3.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="gnupg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="PHP wrapper around the gpgme library"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}"/1.3.2/01-large_file_system.patch
+ done
+
+ php-ext-source-r2_src_prepare
+}