summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-01 17:46:42 +0100
committerSam James <sam@gentoo.org>2024-05-01 17:46:42 +0100
commit62384f141e111f36fa6a87a3a82170a3ef40a809 (patch)
tree48c6d76bf4334fc51696cc267573abcfd4768803 /dev-perl/Text-CSV
parentdev-perl/Text-CSV_XS: add 1.540.0 (diff)
downloadgentoo-62384f141e111f36fa6a87a3a82170a3ef40a809.tar.gz
gentoo-62384f141e111f36fa6a87a3a82170a3ef40a809.tar.bz2
gentoo-62384f141e111f36fa6a87a3a82170a3ef40a809.zip
dev-perl/Text-CSV: add 2.40.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Text-CSV')
-rw-r--r--dev-perl/Text-CSV/Manifest1
-rw-r--r--dev-perl/Text-CSV/Text-CSV-2.40.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Text-CSV/Manifest b/dev-perl/Text-CSV/Manifest
index 0b7356c95c15..4ba6c5ba3d37 100644
--- a/dev-perl/Text-CSV/Manifest
+++ b/dev-perl/Text-CSV/Manifest
@@ -1 +1,2 @@
DIST Text-CSV-2.03.tar.gz 140735 BLAKE2B d40f31623d4b946395968e834cb98b922d75d9515a0d416a3680efd3d739bbd2b429c266132217671fd9f4c27ad6367439d2b11fa60664e2d8b15e58429d80bb SHA512 afd9e81cd2ca9ca9a2c2575c4e540ad09243c1d8b6710dc2b1da472397f99024c768da5ef456948ebd4e06f71b3e5085ef52f191f62c06c6f4a697f70c855769
+DIST Text-CSV-2.04.tar.gz 141037 BLAKE2B 467149c73736d063b9f93a0d9cda8bd2625805702f92559fac91054df0d7948bf70a5cc5a0864bd47649653dd3c83e2d9a7264949a72f72dcfd0235c8930e6e3 SHA512 72673380a955ee888a78aca4188326c1adbdc9508a25752d76eb6f50064181763336b4983bffb944c88110ceb48dde356c092f8189369001513799f220d5021d
diff --git a/dev-perl/Text-CSV/Text-CSV-2.40.0.ebuild b/dev-perl/Text-CSV/Text-CSV-2.40.0.ebuild
new file mode 100644
index 000000000000..1b9fbef45d79
--- /dev/null
+++ b/dev-perl/Text-CSV/Text-CSV-2.40.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=2.04
+inherit perl-module
+
+DESCRIPTION="Manipulate comma-separated value strings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+xs"
+
+RDEPEND="
+ xs? ( >=dev-perl/Text-CSV_XS-1.530.0 )
+ virtual/perl-IO
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/00_pod.t
+ perl-module_src_test
+}