summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/IO-Pager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/IO-Pager')
-rw-r--r--dev-perl/IO-Pager/IO-Pager-0.310.0-r1.ebuild25
-rw-r--r--dev-perl/IO-Pager/IO-Pager-0.340.0.ebuild33
-rw-r--r--dev-perl/IO-Pager/Manifest2
-rw-r--r--dev-perl/IO-Pager/metadata.xml12
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/IO-Pager/IO-Pager-0.310.0-r1.ebuild b/dev-perl/IO-Pager/IO-Pager-0.310.0-r1.ebuild
new file mode 100644
index 000000000000..f659e8e32961
--- /dev/null
+++ b/dev-perl/IO-Pager/IO-Pager-0.310.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_A_EXT=tgz
+MODULE_AUTHOR=JPIERCE
+MODULE_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Select a pager, optionally pipe it output if destination is a TTY"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+SRC_TEST=do
+S=${WORKDIR}/${PN}-0.31
+
+src_prepare() {
+ rm t.pl || die
+ sed -i '/^t.pl/d' MANIFEST || die
+ perl-module_src_prepare
+}
diff --git a/dev-perl/IO-Pager/IO-Pager-0.340.0.ebuild b/dev-perl/IO-Pager/IO-Pager-0.340.0.ebuild
new file mode 100644
index 000000000000..bf74add873d5
--- /dev/null
+++ b/dev-perl/IO-Pager/IO-Pager-0.340.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_A_EXT=tgz
+MODULE_AUTHOR=JPIERCE
+MODULE_VERSION=0.34
+inherit perl-module
+
+DESCRIPTION="Select a pager, optionally pipe it output if destination is a TTY"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-File-Spec
+ dev-perl/File-Which
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do parallel"
+
+src_prepare() {
+ rm t.pl || die
+ sed -i '/^t.pl/d' MANIFEST || die
+ perl-module_src_prepare
+}
diff --git a/dev-perl/IO-Pager/Manifest b/dev-perl/IO-Pager/Manifest
new file mode 100644
index 000000000000..4bfcc305f429
--- /dev/null
+++ b/dev-perl/IO-Pager/Manifest
@@ -0,0 +1,2 @@
+DIST IO-Pager-0.31.tgz 15406 SHA256 e5a61ecae2e81f1349293e2246543da42e8ff61c23bf773e87db561f2e83b939 SHA512 c6e66fc59b951d041d19b3bb57c73860e601732e24c4d3e78e84f6532089b511fc11d071aef21c2f46344813479b592c5ead4438aec47dba487e94ae3452b6a3 WHIRLPOOL 8b798f54e4d730e442eee8016b49f21a2255d66dd0085e69bafe83560831b7eb3aa8e2081f33c8b04bb6c108890e98f702f204ca09733f17f5982bdec4377157
+DIST IO-Pager-0.34.tgz 17100 SHA256 31569ca0af93139e3ca7ce8aae38992930df95b047cffec2db165befca3ce00b SHA512 ee1145d40cb2b851fd2531c6d5d3e88e9c3d2a79303e682f3ce4bfb7a629293a3983a895026baf678ce5053ed09bfcc2b8dba3cdc816acc38f0b1473ab44897e WHIRLPOOL e2f52d454cd13e545057b57a46dc3e13a908cc61112552c4e0c420c2048b396a50d3dfa4274e6bf99a7c76d7ed99fa4a7bc2296b504fe04e2c67446fd25beccd
diff --git a/dev-perl/IO-Pager/metadata.xml b/dev-perl/IO-Pager/metadata.xml
new file mode 100644
index 000000000000..6af72af582a0
--- /dev/null
+++ b/dev-perl/IO-Pager/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">IO-Pager</remote-id>
+ <remote-id type="cpan-module">IO::Pager</remote-id>
+ <remote-id type="cpan-module">IO::Pager::Buffered</remote-id>
+ <remote-id type="cpan-module">IO::Pager::Page</remote-id>
+ <remote-id type="cpan-module">IO::Pager::Unbuffered</remote-id>
+ </upstream>
+</pkgmetadata>