summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-02 12:14:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-02 13:22:39 +0200
commit08a7ccf8ee7293406922f0295c3455a5f10448a3 (patch)
treedce9652d1f32e8501aab08f200125472923e9b6d /dev-ml/uuidm
parentdev-ml/variantslib: convert to opam.eclass (diff)
downloadgentoo-08a7ccf8ee7293406922f0295c3455a5f10448a3.tar.gz
gentoo-08a7ccf8ee7293406922f0295c3455a5f10448a3.tar.bz2
gentoo-08a7ccf8ee7293406922f0295c3455a5f10448a3.zip
dev-ml/uuidm: update to opam.eclass
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/uuidm')
-rw-r--r--dev-ml/uuidm/uuidm-0.9.6.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/dev-ml/uuidm/uuidm-0.9.6.ebuild b/dev-ml/uuidm/uuidm-0.9.6.ebuild
index 8211f3d4d411..f3c7004e85f0 100644
--- a/dev-ml/uuidm/uuidm-0.9.6.ebuild
+++ b/dev-ml/uuidm/uuidm-0.9.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit findlib
+inherit findlib opam
DESCRIPTION="OCaml module implementing 128 bits universally unique identifiers"
HOMEPAGE="http://erratique.ch/software/uuidm"
@@ -14,20 +14,9 @@ SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND="dev-lang/ocaml:=
- dev-ml/cmdliner:="
-DEPEND="${RDEPEND}
- dev-ml/opam"
+RDEPEND="dev-ml/cmdliner:="
+DEPEND="${RDEPEND}"
src_compile() {
ocaml pkg/pkg.ml build || die
}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md README.md
-}