summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:09:21 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:30 +1100
commit0adbd81f89d1fd7bbf5255fe9fa12fc2a5beb7f6 (patch)
tree0a6bc4507e3e76b057d7bf16be8ac6d58de2002b /dev-ml/opam-installer
parentdev-ml/opam-format: Dependency of dev-ml/opam-solver (diff)
downloadgentoo-0adbd81f89d1fd7bbf5255fe9fa12fc2a5beb7f6.tar.gz
gentoo-0adbd81f89d1fd7bbf5255fe9fa12fc2a5beb7f6.tar.bz2
gentoo-0adbd81f89d1fd7bbf5255fe9fa12fc2a5beb7f6.zip
dev-ml/opam-installer: Dependency of eclass/opam.eclass
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/opam-installer')
-rw-r--r--dev-ml/opam-installer/Manifest1
-rw-r--r--dev-ml/opam-installer/metadata.xml11
-rw-r--r--dev-ml/opam-installer/opam-installer-2.0.7.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
new file mode 100644
index 000000000000..b9416004a3a1
--- /dev/null
+++ b/dev-ml/opam-installer/Manifest
@@ -0,0 +1 @@
+DIST opam-full-2.0.7.tar.gz 7929123 BLAKE2B 100acc2c31e97e47b0b584f3a153283593351d49d5e9cdaca42fdcc025b135d9538bd327927950e7e0972b20f561a0ee3d1d1b5b4b87e1e6af31761e311081e7 SHA512 670af4935bba0679c65f6592b7a52b1d429b604eb261e40b13cf72312aeb0bab0c5a76829a555fc5379a0371c352692cbabc46b460fcd9bf32b3cfebdaeceb81
diff --git a/dev-ml/opam-installer/metadata.xml b/dev-ml/opam-installer/metadata.xml
new file mode 100644
index 000000000000..970e090f0dfd
--- /dev/null
+++ b/dev-ml/opam-installer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-installer/opam-installer-2.0.7.ebuild b/dev-ml/opam-installer/opam-installer-2.0.7.ebuild
new file mode 100644
index 000000000000..c95fa47e7079
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+OPAM_SKIP_VALIDATION=yes
+
+inherit opam
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-full-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.02.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/opam-full-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_configure() {
+ econf \
+ --prefix="${EPREFIX}/usr" \
+ --with-mccs \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --mandir="${EPREFIX}/usr/share/man"
+}
+
+src_compile() {
+ sed -e 's/DUNE = .*$/DUNE = /' -i Makefile.config
+ emake lib-ext
+ #passing -jX to the dune build leads to errors
+ #see: https://github.com/ocaml/opam/issues/3585
+ emake DUNE_PROMOTE_ARG="" -j1
+}