summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-16 09:19:56 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-16 09:19:56 +0200
commit76cf489d83918b077242c46c8c4dd5ba243c7c7b (patch)
tree2e8ac0233924d119b0d49461721fe93175910257 /dev-ml/mtime/mtime-1.2.0.ebuild
parentmedia-sound/abcm2ps: bump to 8.14.12 (diff)
downloadgentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.tar.gz
gentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.tar.bz2
gentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.zip
dev-ml/mtime: bump 1.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/mtime/mtime-1.2.0.ebuild')
-rw-r--r--dev-ml/mtime/mtime-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/mtime/mtime-1.2.0.ebuild b/dev-ml/mtime/mtime-1.2.0.ebuild
new file mode 100644
index 000000000000..a6d491ea6add
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-js_of_ocaml false \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}