summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-28 07:54:04 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-28 07:54:04 +0100
commit433d3bbe432eb45f831fea70d2c47d2f8f078449 (patch)
tree0204a996f8816076a0be34f867ea6f79cfff9309 /dev-ml/camlidl
parentnet-irc/unrealircd: add 6.0.1.1 (diff)
downloadgentoo-433d3bbe432eb45f831fea70d2c47d2f8f078449.tar.gz
gentoo-433d3bbe432eb45f831fea70d2c47d2f8f078449.tar.bz2
gentoo-433d3bbe432eb45f831fea70d2c47d2f8f078449.zip
dev-ml/camlidl: 1.09 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camlidl')
-rw-r--r--dev-ml/camlidl/Manifest1
-rw-r--r--dev-ml/camlidl/camlidl-1.09.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/camlidl/Manifest b/dev-ml/camlidl/Manifest
index 812a3761c903..fe60cb01eec5 100644
--- a/dev-ml/camlidl/Manifest
+++ b/dev-ml/camlidl/Manifest
@@ -1 +1,2 @@
DIST camlidl-1.05.tar.gz 100640 BLAKE2B 38cbcebd43ced26c44803608aabdacfbd33734357097a542ee2558223b9699d89cf7be388feba59630b10e4dc3977bffd08c669d3cf676d2136f54a6a8d52aab SHA512 e8857aca818a06f8c861e5f55dddd7e8e3ab1efae51647534460b4f092166709d86c6de1215c792a0489d668d72064ccfb7635e9a6d3854cd5a62f74541a9d18
+DIST camlidl109.tar.gz 125697 BLAKE2B c42e418525b9681a0e7042aea46fb581a1ffa93be416a9214325883407a62bcad7e8fd7a20fd997640deb42ddca394605f5569bc8f363721b8955629459ff49e SHA512 6cab1fa6bc2afba9b97874520eed2887c4fd341b59735854b120aa1ec8822710d9ebfadd1fecff56e629d4a1af7ee73befe6440c5462493f8408bdae8519a1fa
diff --git a/dev-ml/camlidl/camlidl-1.09.ebuild b/dev-ml/camlidl/camlidl-1.09.ebuild
new file mode 100644
index 000000000000..2861e48e26d7
--- /dev/null
+++ b/dev-ml/camlidl/camlidl-1.09.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
+HOMEPAGE="http://caml.inria.fr/camlidl/"
+SRC_URI="https://github.com/xavierleroy/${PN}/archive/${PN}$(ver_rs 0-1 '').tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-${PN}$(ver_rs 0-1 '')
+
+PATCHES=(
+ "${FILESDIR}/nowarn.patch"
+)
+
+src_prepare() {
+ sed -i \
+ -e "s|ar rc|$(tc-getAR) rc|g" \
+ runtime/Makefile.unix \
+ || die
+ default
+}
+
+src_compile() {
+ # Use the UNIX makefile
+ libdir=$(ocamlc -where || die)
+
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix || die
+ sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix || die
+ ln -s Makefile.unix config/Makefile || die
+
+ # Make
+ emake -j1 RANLIB="$(tc-getRANLIB)"
+}
+
+src_test() {
+ einfo "Running tests..."
+ cd tests || die
+ emake CCPP="$(tc-getCXX)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ libdir=$(ocamlc -where || die)
+ dodir "${libdir#${EPREFIX}}"/caml
+
+ dodir /usr/bin
+ # Install
+ emake BINDIR="${ED}/usr/bin" OCAMLLIB="${D}${libdir}" RANLIB="$(tc-getRANLIB)" install
+
+ # Add package header
+ sed -e "s/@VERSION/${P}/g" "${FILESDIR}/META.camlidl" > "${D}${libdir}/META.camlidl" || die
+
+ # Documentation
+ dodoc README Changes
+}