summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-24 11:02:53 +0000
committerSam James <sam@gentoo.org>2024-01-24 11:02:53 +0000
commit18e9cb36fe71ceb4b3ec1a50daf9e406656d478a (patch)
tree0ac2df32df6132cf3f5d7a80b0683c5e314f479d /dev-libs
parentsys-kernel/dracut: Stabilize 060_pre20240104 ppc64, #922811 (diff)
downloadgentoo-18e9cb36fe71ceb4b3ec1a50daf9e406656d478a.tar.gz
gentoo-18e9cb36fe71ceb4b3ec1a50daf9e406656d478a.tar.bz2
gentoo-18e9cb36fe71ceb4b3ec1a50daf9e406656d478a.zip
dev-libs/libcdio: workaround for LLD 17
This is fixed upstream but add the workaround for now. Closes: https://bugs.gentoo.org/915826 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libcdio/libcdio-2.1.0-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/libcdio/libcdio-2.1.0-r1.ebuild b/dev-libs/libcdio/libcdio-2.1.0-r1.ebuild
index 122dfa96d536..cdbeceb6079b 100644
--- a/dev-libs/libcdio/libcdio-2.1.0-r1.ebuild
+++ b/dev-libs/libcdio/libcdio-2.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools libtool multilib-minimal
+inherit autotools flag-o-matic libtool multilib-minimal
DESCRIPTION="A library to encapsulate CD-ROM reading and control"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
@@ -45,11 +45,13 @@ src_prepare() {
default
eautoreconf
-
- elibtoolize # to prevent -L/usr/lib ending up in the linker line wrt 499510
+ elibtoolize # to prevent -L/usr/lib ending up in the linker line wrt #499510
}
multilib_src_configure() {
+ # Workaround for LLD 17, drop after 2.1.0 (bug #915826)
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local util_switch
if ! multilib_is_native_abi || use minimal ; then
util_switch="--without"