summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-08-21 10:29:03 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-08-21 10:45:18 -0400
commite9ce8c858ccc214b8add8f3aafa2b8d351335445 (patch)
tree7c61d1b62871405baa51f7f38b45725f96d3e7d2 /dev-libs/xapian
parentsys-kernel/gentoo-sources: Linux patch 4.19.141 (diff)
downloadgentoo-e9ce8c858ccc214b8add8f3aafa2b8d351335445.tar.gz
gentoo-e9ce8c858ccc214b8add8f3aafa2b8d351335445.tar.bz2
gentoo-e9ce8c858ccc214b8add8f3aafa2b8d351335445.zip
dev-libs/xapian: version bump to 1.4.17
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.17.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index d857dc0c98f2..f557a0eaaf88 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -2,3 +2,4 @@ DIST xapian-core-1.2.25.tar.xz 3253292 BLAKE2B a130e26188c949d0433d017e8d13e7ecf
DIST xapian-core-1.4.14.tar.xz 2970624 BLAKE2B 5bfa5ab36ad4626fcc9a214427f88bdf55e60166939db3a65d3118b426b0ec6754efc10dbcf32456e033292eba3b29f7500679f69a49df15d40c4111322249ed SHA512 c08c9abe87e08491566b7cfa8cda9e2a80e4959a647428b6d82bce7af1c967b4cb463607ffb8976372a980c163923ced36117a66e0b5a1f35659393def3d371b
DIST xapian-core-1.4.15.tar.xz 2988752 BLAKE2B d68d69cdc55c1b62a746620fc90f028819813bb98c0ad0cc130c399a4dd62231b920d24363b61e58d002f65a79a117598455779028de1b26b7a808367f5f2de4 SHA512 f28209acae12a42a345382668f7f7da7a2ce5a08362d0e2af63c9f94cb2adca95366499a7afa0bd9008fbfcca4fd1f2c9221e594fc2a2c740f5899e9f03ecad3
DIST xapian-core-1.4.16.tar.xz 3041132 BLAKE2B 2c009bcdec05542ceae9354e47e8ff9b971ec87d04caf8058711fd6952135620c353f2feabcd869313f55194409944bc7374ce69d626f948461963a7790c3953 SHA512 3d319ab672485e840019ee28b54b1c59bbd535c1802874f58593fb999681c19bff3e776dc19ab5d5bd97734bf01f1408f36ae49e21ca9706ca187db49f8a18a6
+DIST xapian-core-1.4.17.tar.xz 2997700 BLAKE2B 882bc28c9a55731212a5c3ac6da3ad2082e3345cb473eb2c09b80fdd05e700bb31cff6c9a0524b27da015b14655c30548e92a457b48af43279bfd3564cf3c3fa SHA512 3eaf45d31eb9318e292fa052b32b1d9e1035651bdd3c366a0134f4b39d03d987083c19426a3d4b10f60078190fc3388f05b332cba958263bab1abf236c7a3ca7
diff --git a/dev-libs/xapian/xapian-1.4.17.ebuild b/dev-libs/xapian/xapian-1.4.17.ebuild
new file mode 100644
index 000000000000..669d3eb246de
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +inmemory +remote"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+ use remote || myconf="${myconf} --disable-backend-remote"
+
+ myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_test() {
+ emake check VALGRIND=
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ rm -rf "${D}/usr/share/doc/xapian-core-${PV}" || die
+ fi
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ find "${D}" -name "*.la" -type f -delete || die
+}