summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-01 20:28:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-01 20:28:52 +0100
commit9bfaeeddb9aa2667f3f72bce02b8af5a8c5fb43a (patch)
tree6942dc84a2fd188883a162005b61c55d61e44285 /dev-libs/openssl
parentsys-fs/lvm2: Bump to version 2.03.07. Removed old (diff)
downloadgentoo-9bfaeeddb9aa2667f3f72bce02b8af5a8c5fb43a.tar.gz
gentoo-9bfaeeddb9aa2667f3f72bce02b8af5a8c5fb43a.tar.bz2
gentoo-9bfaeeddb9aa2667f3f72bce02b8af5a8c5fb43a.zip
dev-libs/openssl: ebuild code simplification
Added sys-process/procps to BDEPEND because of sysctl usage Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/openssl-1.1.1d-r3.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1d-r3.ebuild b/dev-libs/openssl/openssl-1.1.1d-r3.ebuild
index 932e1a155f54..774605b4bf1d 100644
--- a/dev-libs/openssl/openssl-1.1.1d-r3.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1d-r3.ebuild
@@ -41,6 +41,7 @@ BDEPEND="
test? (
sys-apps/diffutils
sys-devel/bc
+ sys-process/procps
)"
PDEPEND="app-misc/ca-certificates"
@@ -64,14 +65,12 @@ pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return
# must check in pkg_setup; sysctl don't work with userpriv!
- if has test ${FEATURES}; then
- if use sctp; then
- # test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
- # if sctp.auth_enable is not enabled.
- local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)
- if [[ -z "${sctp_auth_status}" || ${sctp_auth_status} != 1 ]]; then
- die "FEATURES=test with USE=sctp requires net.sctp.auth_enable=1!"
- fi
+ if has test ${FEATURES} && use sctp; then
+ # test_ssl_new will fail with "Ensure SCTP AUTH chunks are enabled in kernel"
+ # if sctp.auth_enable is not enabled.
+ local sctp_auth_status=$(sysctl -n net.sctp.auth_enable 2>/dev/null)
+ if [[ -z "${sctp_auth_status}" ]] || [[ ${sctp_auth_status} != 1 ]]; then
+ die "FEATURES=test with USE=sctp requires net.sctp.auth_enable=1!"
fi
fi
}
@@ -120,14 +119,10 @@ src_prepare() {
eapply_user #332661
- if has test ${FEATURES}; then
- if use sctp; then
- if has network-sandbox ${FEATURES}; then
- ebegin "Disabling test '80-test_ssl_new.t' which is known to fail with FEATURES=network-sandbox"
- rm test/recipes/80-test_ssl_new.t || die
- eend $?
- fi
- fi
+ if has test ${FEATURES} && use sctp && has network-sandbox ${FEATURES}; then
+ ebegin "Disabling test '80-test_ssl_new.t' which is known to fail with FEATURES=network-sandbox"
+ rm test/recipes/80-test_ssl_new.t || die
+ eend $?
fi
# make sure the man pages are suffixed #302165