summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:13:10 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:13:10 -0500
commit221d3c39ef1cc7eb31a8ce52413103a29794d352 (patch)
treed3aa6bd34be7d2a15db9fc2d638da8a149d06952 /dev-libs/mpc
parentsys-apps/sandbox: mark 2.10-r4 arm64/m68k/s390/sh stable (diff)
downloadgentoo-221d3c39ef1cc7eb31a8ce52413103a29794d352.tar.gz
gentoo-221d3c39ef1cc7eb31a8ce52413103a29794d352.tar.bz2
gentoo-221d3c39ef1cc7eb31a8ce52413103a29794d352.zip
dev-libs/mpc: version bump to 1.1.0 and add SLOT="0/3"
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs/mpc')
-rw-r--r--dev-libs/mpc/Manifest1
-rw-r--r--dev-libs/mpc/mpc-1.0.3-r2.ebuild (renamed from dev-libs/mpc/mpc-1.0.3-r1.ebuild)4
-rw-r--r--dev-libs/mpc/mpc-1.1.0.ebuild28
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-libs/mpc/Manifest b/dev-libs/mpc/Manifest
index 2d6a9201c8c2..ba1ed7a80387 100644
--- a/dev-libs/mpc/Manifest
+++ b/dev-libs/mpc/Manifest
@@ -1,2 +1,3 @@
DIST mpc-1.0.2.tar.gz 633173 BLAKE2B 9d58d8a41bf4a2d7a82842dc1e76f7fc1376dac950919ae72d1cb04fe70132747a22dcbec91391e1f5aa857c96de553aa21548f20f139742ae4b2463df473d63 SHA512 0e94ba9a20c7374839d2a53a9ed8cce647cc74142b464634fdb9cbaf96e91e43ea13f0b4dab5c06c247e6719de0c0ae03fdcba0c7c4518ee504c545c96da70d0
DIST mpc-1.0.3.tar.gz 669925 BLAKE2B 4b5a1db5220b58070f9356041f44f021c2c9ec46aa4303d0a31e809d649897bc3547e9b06271dae4e80be569ee67e2a84f86b662e05dac0ca36ff87e95fcbd62 SHA512 0028b76df130720c1fad7de937a0d041224806ce5ef76589f19c7b49d956071a683e2f20d154c192a231e69756b19e48208f2889b0c13950ceb7b3cfaf059a43
+DIST mpc-1.1.0.tar.gz 701263 BLAKE2B afd9fefe687b7cd3c3a483e183f366348e34f58f5d713e2f6b38da16e2e382248b446d9da01ea89fe7202b795b08929b7c42c89c2c1e9a57482faf01ee697beb SHA512 72d657958b07c7812dc9c7cbae093118ce0e454c68a585bfb0e2fa559f1bf7c5f49b93906f580ab3f1073e5b595d23c6494d4d76b765d16dde857a18dd239628
diff --git a/dev-libs/mpc/mpc-1.0.3-r1.ebuild b/dev-libs/mpc/mpc-1.0.3-r2.ebuild
index 43c7e147e0d3..d4f00b4f5f78 100644
--- a/dev-libs/mpc/mpc-1.0.3-r1.ebuild
+++ b/dev-libs/mpc/mpc-1.0.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ HOMEPAGE="http://mpc.multiprecision.org/"
SRC_URI="http://www.multiprecision.org/mpc/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
-SLOT="0"
+SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
diff --git a/dev-libs/mpc/mpc-1.1.0.ebuild b/dev-libs/mpc/mpc-1.1.0.ebuild
new file mode 100644
index 000000000000..2ebc852471ef
--- /dev/null
+++ b/dev-libs/mpc/mpc-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="A library for multiprecision complex arithmetic with exact rounding"
+HOMEPAGE="http://mpc.multiprecision.org/"
+SRC_URI="https://ftp.gnu.org/gnu/mpc/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/gmp-5.0.0:0=[${MULTILIB_USEDEP},static-libs?]
+ >=dev-libs/mpfr-3.0.0:0=[${MULTILIB_USEDEP},static-libs?]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}