summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-06 16:00:34 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-06 16:00:34 -0400
commit2a218bae1566e59a476278e3725ba8b8363af2e6 (patch)
tree1096f274cd6e47c973bf011a075114af235f62d3 /dev-libs/libutf8proc
parentdev-lang/polyml: bump to 5.8 (diff)
downloadgentoo-2a218bae1566e59a476278e3725ba8b8363af2e6.tar.gz
gentoo-2a218bae1566e59a476278e3725ba8b8363af2e6.tar.bz2
gentoo-2a218bae1566e59a476278e3725ba8b8363af2e6.zip
dev-libs/libutf8proc: bump to 2.3.0
Also, change upstream to what most revdeps assume: julia-maintained utf8proc. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libutf8proc')
-rw-r--r--dev-libs/libutf8proc/Manifest1
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch21
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild34
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/Manifest b/dev-libs/libutf8proc/Manifest
index e842a463ab67..a49190ee9c9e 100644
--- a/dev-libs/libutf8proc/Manifest
+++ b/dev-libs/libutf8proc/Manifest
@@ -1 +1,2 @@
DIST libutf8proc-2.2.0-1-src.tar.gz 156447 BLAKE2B 1ccf32760bcb8a0d4d9fbf94177ffee97e735a8cb309d5522df1b5ecd5f313a6d0c681209adb066c16ac65573c9c1edaa336b52de1b057a4b74ed6a7e9ca2671 SHA512 eedaafb2fdb3b6bd47da002a48043c26c1cd3c6b96c447a02f2fea19954c1689dcdb5f64b7c662dd8c5de4f971d75b2d69c8483bd29d49675ef47b362ad0c9ad
+DIST libutf8proc-2.3.0.tar.gz 154282 BLAKE2B d9e33cb9e3e587ddcb2c72cb84cb97ed5481a837df788636990f29415beff20dcc80985f2d2354b43f244b6a8122d3bffd9bd1e91c321f22a0ea70015b6ed611 SHA512 3935cd280e14ed570caa89a983b2d56a981e74da9298a1ea26064da78ece288ff48a73306446d3e1d777e6ecd8ea881f7a29169eaae2153cb015daefb8df8656
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
new file mode 100644
index 000000000000..75e9eaac6b53
--- /dev/null
+++ b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index e3310f7..44c8977 100644
+--- a/Makefile
++++ b/Makefile
+@@ -46,7 +46,7 @@ pkgincludedir=$(includedir:$(prefix)/%=%)
+
+ .PHONY: all clean data update manifest install
+
+-all: libutf8proc.a libutf8proc.$(SHLIB_EXT)
++all: libutf8proc.$(SHLIB_EXT)
+
+ clean:
+ rm -f utf8proc.o libutf8proc.a libutf8proc.$(SHLIB_VERS_EXT) libutf8proc.$(SHLIB_EXT)
+@@ -104,7 +104,6 @@ install: libutf8proc.a libutf8proc.$(SHLIB_EXT) libutf8proc.$(SHLIB_VERS_EXT) li
+ mkdir -m 755 -p $(DESTDIR)$(includedir)
+ $(INSTALL) -m 644 utf8proc.h $(DESTDIR)$(includedir)
+ mkdir -m 755 -p $(DESTDIR)$(libdir)
+- $(INSTALL) -m 644 libutf8proc.a $(DESTDIR)$(libdir)
+ $(INSTALL) -m 755 libutf8proc.$(SHLIB_VERS_EXT) $(DESTDIR)$(libdir)
+ mkdir -m 755 -p $(DESTDIR)$(pkgconfigdir)
+ $(INSTALL) -m 644 libutf8proc.pc $(DESTDIR)$(pkgconfigdir)/libutf8proc.pc
diff --git a/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
new file mode 100644
index 000000000000..ea48c910201a
--- /dev/null
+++ b/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P#lib}"
+DESCRIPTION="mapping tool for UTF-8 strings"
+HOMEPAGE="https://github.com/JuliaStrings/utf8proc"
+SRC_URI="https://github.com/JuliaStrings/utf8proc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Don't build or install static libs
+ "${FILESDIR}/${PN}-2.3.0-no-static.patch"
+)
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr libdir=/usr/$(get_libdir) install
+ # This package used to use netsurf's version as an upstream, which lives in
+ # its own little world. Unlike julia's version, it puts its header file
+ # in libutf8proc/utf8proc.h instead of utf8proc.h. The problem is that
+ # revdeps are *already* patched to ajust to this. As a transitionary
+ # measure until we unpatch revdeps, we add a symlink to utf8proc.h.
+ dodir /usr/include/libutf8proc
+ dosym ../utf8proc.h /usr/include/libutf8proc/utf8proc.h
+}