summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-18 15:45:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-18 16:10:22 +0100
commitdbef751215288eb635d194a0a312fa9800e83fe5 (patch)
tree67f7ff685fb81dd3ffdbce3d0ff29bc4ee191758 /dev-lang
parentdev-ruby/asciidoctor: add 2.0.18 (diff)
downloadgentoo-dbef751215288eb635d194a0a312fa9800e83fe5.tar.gz
gentoo-dbef751215288eb635d194a0a312fa9800e83fe5.tar.bz2
gentoo-dbef751215288eb635d194a0a312fa9800e83fe5.zip
dev-lang/python-exec: Bump to 2.4.10
Closes: https://bugs.gentoo.org/886625 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python-exec/Manifest1
-rw-r--r--dev-lang/python-exec/metadata.xml4
-rw-r--r--dev-lang/python-exec/python-exec-2.4.10.ebuild72
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 676993dd9431..8e080cb90d0a 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1 +1,2 @@
+DIST python-exec-2.4.10.tar.bz2 84412 BLAKE2B 1fe79e0d31a48954959a5556f96c3868fcf762ebc473d17f03e78a95cca83ab40b4933b7e42bc5751b0546e6229f9fdde9171c3fcbdd184f993536f944870491 SHA512 8c7d3c6b1fa362c8c97ec74ee01b5a195dc409d883408033e9709773b6059deb5291f6e63df6d9a4e42a0951aad4a1d513d4baa00ad9ff3dce3e1d2d38b694e1
DIST python-exec-2.4.9.tar.bz2 84300 BLAKE2B 77ad193f2602db392830eb4e2632562cfa1ca09bdc710e35dc141a036230ac21e63a51d297184740d85e6c3be8cb4b7ffefef270e51533ff15250f474437a52e SHA512 ad520dc7724bc71629e238226cd795214860e0a090a065dc85f782e6bd86c30ba46d58cb80d46221f4ff4a146332244b6670335a8f31f630088f477588ed8293
diff --git a/dev-lang/python-exec/metadata.xml b/dev-lang/python-exec/metadata.xml
index 95267dce890c..c942a12a85fc 100644
--- a/dev-lang/python-exec/metadata.xml
+++ b/dev-lang/python-exec/metadata.xml
@@ -10,8 +10,8 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/python-exec/issues/</bugs-to>
- <remote-id type="github">mgorny/python-exec</remote-id>
+ <bugs-to>https://github.com/projg2/python-exec/issues/</bugs-to>
+ <remote-id type="github">projg2/python-exec</remote-id>
</upstream>
<use>
<flag name="native-symlinks">
diff --git a/dev-lang/python-exec/python-exec-2.4.10.ebuild b/dev-lang/python-exec/python-exec-2.4.10.ebuild
new file mode 100644
index 000000000000..dd052a670920
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.4.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit python-any-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://github.com/projg2/python-exec/"
+SRC_URI="https://github.com/projg2/python-exec/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/python-exec-conf
+ !<=dev-lang/python-2.7.18-r3:2.7"
+BDEPEND="
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+
+python_check_deps() {
+ python_has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local pyimpls=() i EPYTHON
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
+ if use "python_targets_${i}"; then
+ _python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
+ fi
+ done
+
+ local myconf=(
+ --with-fallback-path="${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
+ --with-python-impls="${pyimpls[*]}"
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if use native-symlinks; then
+ local programs=( python python3 )
+ local scripts=( python-config python3-config 2to3 idle pydoc pyvenv )
+
+ local f
+ for f in "${programs[@]}"; do
+ # symlink the C wrapper for python to avoid shebang recursion
+ # bug #568974
+ dosym python-exec2c /usr/bin/"${f}"
+ done
+ for f in "${scripts[@]}"; do
+ # those are python scripts (except for new python-configs)
+ # so symlink them via the python wrapper
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
+ fi
+}