summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 03:14:50 +0000
committerSam James <sam@gentoo.org>2021-06-15 03:15:11 +0000
commit19c04306aa8283cc7adf787a1067aa75537ef14e (patch)
tree200a510b9c9f9e33fa7580757ea87f48f13fc02d /dev-lang/maude
parentdev-python/grpcio: fix whitespace (diff)
downloadgentoo-19c04306aa8283cc7adf787a1067aa75537ef14e.tar.gz
gentoo-19c04306aa8283cc7adf787a1067aa75537ef14e.tar.bz2
gentoo-19c04306aa8283cc7adf787a1067aa75537ef14e.zip
dev-lang/maude: fix build with GCC 11
Closes: https://bugs.gentoo.org/787851 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/maude')
-rw-r--r--dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch60
-rw-r--r--dev-lang/maude/maude-2.7.ebuild3
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch b/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch
new file mode 100644
index 000000000000..b903d50e22bc
--- /dev/null
+++ b/dev-lang/maude/files/maude-2.7-fix-build-with-gcc11.patch
@@ -0,0 +1,60 @@
+https://bugs.gentoo.org/787851
+
+From 6d448928a88f586195dadd9fae9cb1b19e589d94 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 15 Jun 2021 03:05:34 +0000
+Subject: [PATCH] Fix build with GCC 11
+diff --git a/src/ObjectSystem/configSymbol.hh b/src/ObjectSystem/configSymbol.hh
+index 90b00d9..d037dab 100644
+--- a/src/ObjectSystem/configSymbol.hh
++++ b/src/ObjectSystem/configSymbol.hh
+@@ -50,7 +50,7 @@ public:
+ private:
+ struct symbolLt
+ {
+- bool operator()(const Symbol* d1, const Symbol* d2)
++ bool operator()(const Symbol* d1, const Symbol* d2) const
+ {
+ return d1->compare(d2) < 0;
+ }
+diff --git a/src/ObjectSystem/objectMap.cc b/src/ObjectSystem/objectMap.cc
+index 0dbcaf0..722aa29 100644
+--- a/src/ObjectSystem/objectMap.cc
++++ b/src/ObjectSystem/objectMap.cc
+@@ -50,7 +50,7 @@ ConfigSymbol::MessageQueue::markReachableNodes() const
+
+ struct ConfigSymbol::dagNodeLt
+ {
+- bool operator()(const DagNode* d1, const DagNode* d2)
++ bool operator()(const DagNode* d1, const DagNode* d2) const
+ {
+ return d1->compare(d2) < 0;
+ }
+diff --git a/src/ObjectSystem/objectSystemRewritingContext.hh b/src/ObjectSystem/objectSystemRewritingContext.hh
+index 33785ec..32f4d94 100644
+--- a/src/ObjectSystem/objectSystemRewritingContext.hh
++++ b/src/ObjectSystem/objectSystemRewritingContext.hh
+@@ -62,7 +62,7 @@ protected:
+ private:
+ struct dagNodeLt
+ {
+- bool operator()(const DagNode* d1, const DagNode* d2)
++ bool operator()(const DagNode* d1, const DagNode* d2) const
+ {
+ return d1->compare(d2) < 0;
+ }
+diff --git a/src/Mixfix/entity.hh b/src/Mixfix/entity.hh
+index eb8ad58..a221de4 100644
+--- a/src/Mixfix/entity.hh
++++ b/src/Mixfix/entity.hh
+@@ -53,7 +53,7 @@ public:
+ private:
+ struct UserLt
+ {
+- bool operator()(const User* user1, const User* user2)
++ bool operator()(const User* user1, const User* user2) const
+ {
+ //
+ // Direct < comparison of unrelated pointers is undefined. But since the casting
+--
+2.32.0
diff --git a/dev-lang/maude/maude-2.7.ebuild b/dev-lang/maude/maude-2.7.ebuild
index 01957fb2a5e5..72d88da7e51b 100644
--- a/dev-lang/maude/maude-2.7.ebuild
+++ b/dev-lang/maude/maude-2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.6-search-datadir.patch"
"${FILESDIR}/${PN}-2.7-bison-parse-param.patch"
"${FILESDIR}/${PN}-2.7-AR.patch"
+ "${FILESDIR}/${PN}-2.7-fix-build-with-gcc11.patch"
)
src_prepare() {