summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-06-14 14:48:27 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-06-14 15:29:56 +0200
commit2a2e7dcf62202165bfa2b77cfa0138eb4bd7a29c (patch)
treea64e958d551bb014d8e1fc3ff97afb0434daab1a /dev-lang/execline
parentdev-libs/skalibs: add 2.14.2.0 (diff)
downloadgentoo-2a2e7dcf62202165bfa2b77cfa0138eb4bd7a29c.tar.gz
gentoo-2a2e7dcf62202165bfa2b77cfa0138eb4bd7a29c.tar.bz2
gentoo-2a2e7dcf62202165bfa2b77cfa0138eb4bd7a29c.zip
dev-lang/execline: add 2.9.6.0
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-lang/execline')
-rw-r--r--dev-lang/execline/Manifest1
-rw-r--r--dev-lang/execline/execline-2.9.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/execline/Manifest b/dev-lang/execline/Manifest
index 407aa93c6870..bf54495faacb 100644
--- a/dev-lang/execline/Manifest
+++ b/dev-lang/execline/Manifest
@@ -1 +1,2 @@
DIST execline-2.9.5.1.tar.gz 110874 BLAKE2B bef3cb560f00c01c96065429220017315edc8378403c73e4a0edba67ee248f76ca849cd8a107756251db9844d3ac650259b33db2f93abc1c7aa4f68995b5b624 SHA512 11bfd825b0b72cba118eff9ecb97672d0c015e0bd50c7c8f83e101ee41c323b3a3c82e42fed75b6bc65ab6edb85a8bbeef8900b594cf651825b6313a5123c88f
+DIST execline-2.9.6.0.tar.gz 111660 BLAKE2B 42baed36228b1e6a370d6d4c18829be7f517812ce9e3838e5b102d0fe58ac48ecd84f17caef89e9a07b3b149ed9b38b3b00f7eef810c231995c8e5ecbf07a770 SHA512 1c5233b0f17b4c92ab2e9e8700b47c8429ad97962bcb7c83190d0b3251b26584e591d77418eca77e8112cdecd24eec50aaca7da1dbb506120931bbda39f2b7cb
diff --git a/dev-lang/execline/execline-2.9.6.0.ebuild b/dev-lang/execline/execline-2.9.6.0.ebuild
new file mode 100644
index 000000000000..6eff46cb134a
--- /dev/null
+++ b/dev-lang/execline/execline-2.9.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="A non-interactive scripting language"
+HOMEPAGE="https://www.skarnet.org/software/execline/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2).4"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-libs/skalibs-2.14.0.0:="
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ optfeature "man pages" app-doc/execline-man-pages
+}