summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xml-security
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xml-security')
-rw-r--r--dev-java/xml-security/Manifest1
-rw-r--r--dev-java/xml-security/files/1.5.7-build.xml.patch38
-rw-r--r--dev-java/xml-security/metadata.xml5
-rw-r--r--dev-java/xml-security/xml-security-1.5.7.ebuild57
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-java/xml-security/Manifest b/dev-java/xml-security/Manifest
new file mode 100644
index 000000000000..50df9d104a7d
--- /dev/null
+++ b/dev-java/xml-security/Manifest
@@ -0,0 +1 @@
+DIST xml-security-bin-1_5_7.zip 9164667 SHA256 37e31a3f80da74efddc5aabc9515366741aa68dfa3f71e903c0a870dec871011 SHA512 ae8e538fe7c90013a89d139358efc06d8921b1b0050a686dcacd123f5a8a8f100be163e88fef59998ea0ba27ebe9855f06d1f33b1ac92fa3f31acbce9934bd36 WHIRLPOOL faa1cd472b013a69ca38505806630aa423706a9a95f83a8bdd98813c8fc870875def6cf5c5157b1409280c362fb4070a8b9822c981bd8bc49b5a3688ccfd1b70
diff --git a/dev-java/xml-security/files/1.5.7-build.xml.patch b/dev-java/xml-security/files/1.5.7-build.xml.patch
new file mode 100644
index 000000000000..294c059574d6
--- /dev/null
+++ b/dev-java/xml-security/files/1.5.7-build.xml.patch
@@ -0,0 +1,38 @@
+diff --git a/xml-security-1_5_5/build.xml b/xml-security-1_5_5/build.xml
+index d959d67..d91f98e 100644
+--- a/xml-security-1_5_5/build.xml
++++ b/xml-security-1_5_5/build.xml
+@@ -668,7 +668,7 @@
+ </target>
+
+ <target name="build.jar"
+- depends="manifest,build.src,build.test,build.samples">
++ depends="manifest,build.src">
+
+ <!-- Main Library -->
+ <jar basedir="${dir.build.bin}"
+@@ -678,24 +678,6 @@
+ manifest="${jar.manifest}">
+ <metainf file="${dir.manifest}/*.txt"/>
+ </jar>
+-
+- <!-- Samples -->
+- <jar basedir="${dir.build.samples}"
+- excludes="org/apache/xml/security/temp/**"
+- includes="org/apache/**, javax/xml/crypto/**"
+- destfile="${jar.samples}"
+- manifest="${jar.manifest}">
+- <metainf file="${dir.manifest}/*.txt"/>
+- </jar>
+-
+- <!-- Tests -->
+- <jar basedir="${dir.build.test}"
+- excludes="org/apache/xml/security/temp/**"
+- includes="org/apache/**, javax/xml/crypto/**"
+- destfile="${jar.tests}"
+- manifest="${jar.manifest}">
+- <metainf file="${dir.manifest}/*.txt"/>
+- </jar>
+ </target>
+
+ <target name="build.src.jar"
diff --git a/dev-java/xml-security/metadata.xml b/dev-java/xml-security/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/xml-security/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/xml-security/xml-security-1.5.7.ebuild b/dev-java/xml-security/xml-security-1.5.7.ebuild
new file mode 100644
index 000000000000..212ad77ba35b
--- /dev/null
+++ b/dev-java/xml-security/xml-security-1.5.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PV=${PV//./_}
+DESCRIPTION="An implementation of the primary security standards for XML"
+HOMEPAGE="http://santuario.apache.org/"
+SRC_URI="mirror://apache/santuario/java-library/${MY_PV}/${PN}-bin-${MY_PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="
+ dev-java/commons-logging:0
+ dev-java/xalan:0
+"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+DEPEND="${CDEPEND}
+ test? ( dev-java/junit:4 )
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="commons-logging,xalan"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}"/build/xmlsec-${PV}.jar
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
+EANT_TEST_TARGET="build.test test"
+WANT_ANT_TASKS="ant-junit"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-build.xml.patch"
+ find "${S}" -name "*.jar" -delete || die
+ rm "${S}"/src/test/java/org/apache/xml/security/test/utils/OldApiTest.java || die
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/build/xmlsec-${PV}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc "${S}"/src/main/java/*
+ use doc && java-pkg_dojavadoc "${S}"/build/docs/html/javadoc
+}
+
+src_test() {
+ java-pkg-2_src_test
+}