summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-10-17 15:02:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2019-10-17 16:02:29 +0200
commit45e525301bdf27cb1ab9e007b07fb9f8faf75306 (patch)
tree265e41e38f1566efca69881f41c99b2f1378b978 /dev-java/ant-core
parentapp-emacs/mailcrypt: Fix backquotes patch. (diff)
downloadgentoo-45e525301bdf27cb1ab9e007b07fb9f8faf75306.tar.gz
gentoo-45e525301bdf27cb1ab9e007b07fb9f8faf75306.tar.bz2
gentoo-45e525301bdf27cb1ab9e007b07fb9f8faf75306.zip
dev-java/ant-core-1.10.7: bump
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-core')
-rw-r--r--dev-java/ant-core/Manifest2
-rw-r--r--dev-java/ant-core/ant-core-1.10.7.ebuild123
2 files changed, 125 insertions, 0 deletions
diff --git a/dev-java/ant-core/Manifest b/dev-java/ant-core/Manifest
index 20081eaa123e..c3eadc79a6fd 100644
--- a/dev-java/ant-core/Manifest
+++ b/dev-java/ant-core/Manifest
@@ -1,4 +1,6 @@
DIST ant-1.10.5-r1-gentoo.tar.bz2 6400 BLAKE2B 349a45ee678217ee31ae2f6e982ceec2d31138dcb58e614f496125d7d9bc01a0fa3630be069fbf0d131f4006cb7912597c31392bc82ab7f9b0a1189bbe9a763e SHA512 adf544c151f46df8a7fb7f7d33450f9a2390f568dd4c7b1c0e8850b1a155ea0ddc1f834d869d657806570d59af2d194cb443ddfc653627967246f3b38e264b12
+DIST ant-1.10.7-gentoo.tar.bz2 6686 BLAKE2B 77e5850b68ab079f26722b5b2ff1afb29a35197afb79f80ae2f775855e2d8f3a478324b1175e9a73695b4e6a6798bf4458dc84d2f763a1d72c331505d31303ea SHA512 f5c5a2ea99a780413a71799d56e783f3ac861169bd7f29c3a85d039f61240abb91ed223eeb111c67a6a1328a6cf2203d7cbf93ad762e49bc11f9a948e7f2091c
DIST ant-1.9.13-r1-gentoo.tar.bz2 7208 BLAKE2B 6f041a69f5f8e38e95b26030cf4d730ed22b071ad1d6e87ab1fb2707e2b40c7e23e1c8f7759d6904ad2b25793a7d9b2ead1c2649b6b029296cd9d05bec4ea296 SHA512 5b105ea00fbc7d6f63c0016b288f5e46a81b89cc46015e2ffcb2a4d41f915331ac8f8183752fea547396f204748132f6ce7aa7b3e6f6181c4983b4eb7ee84d54
DIST apache-ant-1.10.5-src.tar.bz2 4465063 BLAKE2B 3cab99ae4a4800a42af3595ca6955877e3ab90c2df7086636b0f1ae0e3a45912f0c815164378616b758d76afe0a2f23cc0af6094d2f84fe17f29c3abe2e6f9aa SHA512 082dad03db4fb09b36560bd5e1fbd53f456eecad06d95140569661b6509861bb9b87b87843ef2f30a5de18c549dd993209aa17b47ac77d450f573309a272950e
+DIST apache-ant-1.10.7-src.tar.bz2 4530166 BLAKE2B 6998fffbda6a0adbe3434ef0013b3e669ec8f15a09d9a5917509733f3232a538e9be83758b9eacccd673522812a8d482e1fd526d5493634d9c08759f47bfc7a7 SHA512 5849e81aa037b9ba7f4e67057a0cde50301d183fc244673c7f11e34997b11d21c33306c07ab820bf60d454afa8ad5b159c3442427c8cb5403896f29ed179b10d
DIST apache-ant-1.9.13-src.tar.bz2 3954912 BLAKE2B 1ec249bb33f54fde80ba8a17248755e7412eb3415b14a03f0558bcc220c3eb47dc88128d435e59f10118f74c31eab8eea83f5d5db09640e1a5aaf08bac1490c1 SHA512 27cd4566df35a09873f32f897ea47c55ad3940f48440b52ce9838e5fcd9e8ca55b27151a25597f21c430cd2921e3b2b6b105962d0d40294a1eb06ed689b05810
diff --git a/dev-java/ant-core/ant-core-1.10.7.ebuild b/dev-java/ant-core/ant-core-1.10.7.ebuild
new file mode 100644
index 000000000000..004db50c84b5
--- /dev/null
+++ b/dev-java/ant-core/ant-core-1.10.7.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Don't depend on itself.
+JAVA_ANT_DISABLE_ANT_CORE_DEP="true"
+
+# Rewriting build.xml files for the testcases has no use at the moment.
+JAVA_PKG_BSFIX_ALL="no"
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2 prefix
+
+MY_P="apache-ant-${PV}"
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files"
+HOMEPAGE="https://ant.apache.org/"
+SRC_URI="https://archive.apache.org/dist/ant/source/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~fordfrog/distfiles/ant-${PV}-gentoo.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND=">=virtual/jdk-1.8:*
+ !dev-java/ant-tasks
+ !dev-java/ant-optional"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+PATCHES=( "${WORKDIR}/${PV}-build.patch" "${WORKDIR}/${PV}-launch.patch" )
+
+src_prepare() {
+ default
+
+ eprefixify "${S}/src/script/ant"
+
+ # Fixes bug 556008.
+ java-ant_xml-rewrite -f build.xml \
+ -c -e javadoc \
+ -a failonerror \
+ -v "false"
+
+ # See bug #196080 for more details.
+ java-ant_bsfix_one build.xml
+ java-pkg-2_src_prepare
+
+ # Remove JDK9+ stuff
+ einfo "Removing JDK9+ classes (Jmod and Link)"
+ rm "${S}"/src/main/org/apache/tools/ant/taskdefs/modules/{Jmod,Link}.java
+}
+
+src_compile() {
+ export ANT_HOME=""
+ # Avoid error message that package ant-core was not found
+ export ANT_TASKS="none"
+
+ local bsyscp
+
+ # This ensures that when building ant with bootstrapped ant,
+ # only the source is used for resolving references, and not
+ # the classes in bootstrapped ant but jikes in kaffe has issues with this...
+ if ! java-pkg_current-vm-matches kaffe; then
+ bsyscp="-Dbuild.sysclasspath=ignore"
+ fi
+
+ CLASSPATH="$(java-config -t)" ./build.sh ${bsyscp} jars dist-internal \
+ $(use_doc javadocs) || die "build failed"
+}
+
+src_install() {
+ dodir /usr/share/ant/lib
+
+ for jar in ant.jar ant-bootstrap.jar ant-launcher.jar ; do
+ java-pkg_dojar build/lib/${jar}
+ dosym ../../${PN}/lib/${jar} /usr/share/ant/lib/${jar}
+ done
+
+ dobin src/script/ant
+
+ dodir /usr/share/${PN}/bin
+ for each in antRun antRun.pl runant.pl runant.py ; do
+ dobin "${S}/src/script/${each}"
+ dosym ../../../bin/${each} /usr/share/${PN}/bin/${each}
+ done
+ dosym ../${PN}/bin /usr/share/ant/bin
+
+ insinto /usr/share/${PN}
+ doins -r dist/etc
+ dosym ../${PN}/etc /usr/share/ant/etc
+
+ echo "ANT_HOME=\"${EPREFIX}/usr/share/ant\"" > "${T}/20ant"
+ doenvd "${T}/20ant"
+
+ dodoc NOTICE README WHATSNEW KEYS
+
+ if use doc; then
+ dodoc -r manual/*
+ java-pkg_dojavadoc --symlink manual/api build/javadocs
+ fi
+
+ use source && java-pkg_dosrc src/main/*
+}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ if _ver_compare ${REPLACING_VERSIONS} 1.7.0 -eq 1; then
+ elog "The way of packaging ant in Gentoo has changed significantly since"
+ elog "the 1.7.0 version, For more information, please see:"
+ elog "https://www.gentoo.org/proj/en/java/ant-guide.xml"
+ fi
+
+ if _ver_compare ${REPLACING_VERSIONS} 1.7.1 -eq 1; then
+ elog "Since 1.7.1, the ant-tasks meta-ebuild has been removed and its USE"
+ elog "flags have been moved to dev-java/ant."
+ fi
+ fi
+}