summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 12:46:50 +1000
committerSam James <sam@gentoo.org>2022-07-23 05:06:21 +0100
commit5441d6285e6a5b6c7eee323817e5a584b5efb846 (patch)
tree5396b9ef5eaf521d09759a09e7a8e2b6c80478ff /dev-haskell/yesod
parentdev-haskell/yesod-form: add 1.7.0 (diff)
downloadgentoo-5441d6285e6a5b6c7eee323817e5a584b5efb846.tar.gz
gentoo-5441d6285e6a5b6c7eee323817e5a584b5efb846.tar.bz2
gentoo-5441d6285e6a5b6c7eee323817e5a584b5efb846.zip
dev-haskell/yesod: add 1.6.2
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/yesod')
-rw-r--r--dev-haskell/yesod/Manifest1
-rw-r--r--dev-haskell/yesod/yesod-1.6.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/yesod/Manifest b/dev-haskell/yesod/Manifest
index 1046bb622873..f536f5a038b4 100644
--- a/dev-haskell/yesod/Manifest
+++ b/dev-haskell/yesod/Manifest
@@ -1 +1,2 @@
DIST yesod-1.6.1.0.tar.gz 9794 BLAKE2B b0306995ca93646d4ed1eb58356c706b1a4fb773cbcf3dd7649405484af1f077f7f22c9d1792d9fb34aca11dc357dd7d527bbc5e5d6f60d24baa0b3797f60255 SHA512 712eed39b64f515cb949186ddb950133cc2daccde6d4a9b0115809e5f4726a957b2809ee785b348971c617b3d173bcd40776b065f5bf1d68b79af12905ada77a
+DIST yesod-1.6.2.tar.gz 9927 BLAKE2B 551b6a659180536dae72cea4a342f7451eb005cb79bd06cb5af38e41052956c40b93e2368da307ccdcc8bb5e0ea718ae89e7fd858b3273d8823787a333f11da1 SHA512 7c7a3e191ce91ac4070179bdfdae89c60e91c702d9141bb90fcb7095d175727a3f0648221ea151b6e1f5c37a236f55c37aaf963c526e4ced572c19bd6fb0b3a8
diff --git a/dev-haskell/yesod/yesod-1.6.2.ebuild b/dev-haskell/yesod/yesod-1.6.2.ebuild
new file mode 100644
index 000000000000..dedbcc5adbe0
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/fast-logger:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3:=[profile?]
+ >=dev-haskell/yaml-0.8.17:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.6:=[profile?] <dev-haskell/yesod-form-1.8:=[profile?]
+ >=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"