summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-24 00:01:05 +0100
committerSam James <sam@gentoo.org>2022-07-24 00:01:07 +0100
commit841ae503668578a85e411ad9a3654e216707f718 (patch)
tree5a017a78f0aa3e286e1dbce35f08ec5c777d2628 /dev-haskell/tar
parentdev-haskell/microlens-aeson: add 2.5.0, drop 2.3.0.4, 2.3.1 (diff)
downloadgentoo-841ae503668578a85e411ad9a3654e216707f718.tar.gz
gentoo-841ae503668578a85e411ad9a3654e216707f718.tar.bz2
gentoo-841ae503668578a85e411ad9a3654e216707f718.zip
dev-haskell/tar: fixup deps (sync w/ ::haskell)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tar')
-rw-r--r--dev-haskell/tar/Manifest1
-rw-r--r--dev-haskell/tar/metadata.xml10
-rw-r--r--dev-haskell/tar/tar-0.5.1.1-r2.ebuild46
3 files changed, 48 insertions, 9 deletions
diff --git a/dev-haskell/tar/Manifest b/dev-haskell/tar/Manifest
index e58ad8f4dbde..3d6a1a40e251 100644
--- a/dev-haskell/tar/Manifest
+++ b/dev-haskell/tar/Manifest
@@ -1 +1,2 @@
+DIST tar-0.5.1.1-rev4.cabal 5459 BLAKE2B 6feab7587be8c2533c200cc9f57411f3cb4f5a31dbff09502c983c181b6dc0c8521e8db02fd0a3f14c3237dce4872d0adfe739452ed38252f7696dd80de80297 SHA512 aa1c41951d93ce368cffeb6a5ea43b70cca042557e0509c7901901710b2c01b715c37923e9325fb438ad83c2a50c8f227777641e9931700ba0bce6ae6d974200
DIST tar-0.5.1.1.tar.gz 39155 BLAKE2B 8e85489e3b43044dab8ec4405413873c2be4d50cfd4a5adc80e3ec231428a120db1faa033d2e57643dad40f18a934a381f3d5657838aad42d2aa7eea951c1faf SHA512 8d0a8d3ae178570e0842a2321a7fc86a6bba28c471ec27bafbc07fc4ac0e4183f8113c99ebc7126dc71759c33083791122be32563fb0d5a2b2d39cb3b36171f2
diff --git a/dev-haskell/tar/metadata.xml b/dev-haskell/tar/metadata.xml
index 6b08cc023203..937381521944 100644
--- a/dev-haskell/tar/metadata.xml
+++ b/dev-haskell/tar/metadata.xml
@@ -3,14 +3,6 @@
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library is for working with .tar@ archive files. It
- can read and write a range of common variations of archive
- format including V7, USTAR, POSIX and GNU formats. It provides
- support for packing and unpacking portable archives. This
- makes it suitable for distribution but not backup because
- details like file ownership and exact permissions are not
- preserved.
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/tar/tar-0.5.1.1-r2.ebuild b/dev-haskell/tar/tar-0.5.1.1-r2.ebuild
new file mode 100644
index 000000000000..cd48fca21e69
--- /dev/null
+++ b/dev-haskell/tar/tar-0.5.1.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+CABAL_HACKAGE_REVISION="4"
+inherit haskell-cabal
+RESTRICT="test" # Test deps need porting
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="Reading, writing and manipulating \".tar\" archive files"
+HOMEPAGE="https://hackage.haskell.org/package/tar"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( dev-haskell/bytestring-handle
+# >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+# >=dev-haskell/tasty-0.10 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}