summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-23 15:49:59 -0500
committerSam James <sam@gentoo.org>2024-01-24 06:54:40 +0000
commit2b24ee1bfeab752876df2d1d1deba201c5f6da88 (patch)
treebf1641d0c2f99155c44890a72ece896ad92bad55 /dev-db
parentdev-db/mysql: migrate checking for enabled lto, to tc-is-lto (diff)
downloadgentoo-2b24ee1bfeab752876df2d1d1deba201c5f6da88.tar.gz
gentoo-2b24ee1bfeab752876df2d1d1deba201c5f6da88.tar.bz2
gentoo-2b24ee1bfeab752876df2d1d1deba201c5f6da88.zip
dev-db/percona-server: migrate checking for enabled lto, to tc-is-lto
This toolchain func was recently added, and vis a lot more reliable than get-flagq. mysql attempts to manually handle some edge case, for example if the active flags contain `-flto -fno-lto` then tc-is-lto gets it correct but with is-flagq we have to manually check both. On the other hand, mysql doesn't handle detecting -flto=8. Using tc-is-lto is the preferred way to handle this from now on. We would rather use this wherever possible. Drops a bit of pointless logging. We don't need an `einfo` to tell us that make.conf is being respected. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
index ee421f4b5a3f..ebf0aeb32043 100644
--- a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
+++ b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -259,15 +259,10 @@ src_configure() {
-DWITH_ROUTER=$(usex router ON OFF)
)
- if is-flagq -fno-lto ; then
- einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
- mycmakeargs+=( -DWITH_LTO=OFF )
- elif is-flagq -flto ; then
- einfo "LTO forced via {C,CXX,F,FC}FLAGS"
- myconf+=( -DWITH_LTO=ON )
+ if tc-is-lto ; then
+ mycmakeargs+=( -DWITH_LTO=ON )
else
- # Disable automagic
- myconf+=( -DWITH_LTO=OFF )
+ mycmakeargs+=( -DWITH_LTO=OFF )
fi
if use test ; then