summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-06 10:28:21 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-06 10:31:42 +0200
commit4568616a2db47ffaad650f53ffb096be88e846a0 (patch)
tree3f735e54394a5dcef73bfe03267ef31eb0bed989 /dev-cpp
parentdev-tcltk/tablelist: add 6.15.1 (diff)
downloadgentoo-4568616a2db47ffaad650f53ffb096be88e846a0.tar.gz
gentoo-4568616a2db47ffaad650f53ffb096be88e846a0.tar.bz2
gentoo-4568616a2db47ffaad650f53ffb096be88e846a0.zip
dev-cpp/tbb: drop 2019.8, 2020.2
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/Manifest2
-rw-r--r--dev-cpp/tbb/tbb-2019.8.ebuild141
-rw-r--r--dev-cpp/tbb/tbb-2020.2.ebuild151
3 files changed, 0 insertions, 294 deletions
diff --git a/dev-cpp/tbb/Manifest b/dev-cpp/tbb/Manifest
index 4fb83d37f0ea..d2d3f1d78cf8 100644
--- a/dev-cpp/tbb/Manifest
+++ b/dev-cpp/tbb/Manifest
@@ -1,3 +1 @@
-DIST tbb-2019.8.tar.gz 2580540 BLAKE2B 1cddb0c8ade6f6363811b7f9b323a2bb7739a18114acd56e1b4a13f33904ddff8cb6aec9b4b0add995cd307ff7815f0b55ce33fa64b7dd92c0062fbaa13d0833 SHA512 924a8dde011452a2c46c5152942a9835e76fe5610e08b69eb0e985de3fb46bdb49f0f628d10fa7704428f6e61ec63f7002da5399d47da6ee6004fa236d346dc8
-DIST tbb-2020.2.tar.gz 2637172 BLAKE2B 6b6e65732d3971f7374058513004ca3cfc3855b83c0a2dde59d50e08c26ff220470e31db86f4ab9f009c7e02e454a00a348730e63c829aa8d217320f7879cfc9 SHA512 6d7412fa6ce12d27736af3c8942c5ab5ea6945dd3ca93f309535c0dba3ff757d6507a5ffc3bcd73e6fdcda043cdedfa657631b25ae86fbf221d0f1d66a85b48f
DIST tbb-2020.3.tar.gz 2639788 BLAKE2B 3e92bccdc8179fc049379ccbb8ad7f615623177abc61d813b1a601020c345137bfd7d4c4600cf5b0d587e5ebef677635c3c8124d06b05fdd3325128ed8c9f84a SHA512 04c4b5501418792827190691d03d20d4dc1fd3cbbcf459a4d40c5c2281d964e658f31f133ad3907b78e17ed04f4ff16728ed89487ed0ce2cb239f23feb34bd87
diff --git a/dev-cpp/tbb/tbb-2019.8.ebuild b/dev-cpp/tbb/tbb-2019.8.ebuild
deleted file mode 100644
index da66dd2bd839..000000000000
--- a/dev-cpp/tbb/tbb-2019.8.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal multilib toolchain-funcs
-
-PV1="$(ver_cut 1)"
-PV2="$(ver_cut 2)"
-MY_PV="${PV1}_U${PV2}"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="https://www.threadingbuildingblocks.org"
-SRC_URI="https://github.com/intel/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DOCS=( CHANGES README README.md doc/Release_Notes.txt )
-
-src_prepare() {
- default
-
- find include -name \*.html -delete || die
-
- # Give it a soname on FreeBSD
- echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
- # Set proper versionning on FreeBSD
- sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
-
- use debug || sed -i -e '/_debug/d' Makefile
-}
-
-multilib_src_configure() {
- # pc files are for debian and fedora compatibility
- # some deps use them
- cat <<-EOF > ${PN}.pc.template
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Cflags: -I\${includedir}
- EOF
- cp ${PN}.pc.template ${PN}.pc || die
- cat <<-EOF >> ${PN}.pc
- Libs: -L\${libdir} -ltbb
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc.pc || die
- cat <<-EOF >> ${PN}malloc.pc
- Libs: -L\${libdir} -ltbbmalloc
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc_proxy.pc || die
- cat <<-EOF >> ${PN}malloc_proxy.pc
- Libs: -L\${libdir} -ltbbmalloc_proxy
- Libs.private: -lrt
- Requires: tbbmalloc
- EOF
-}
-
-local_src_compile() {
- cd "${S}"
-
- local comp arch
-
- case ${MULTILIB_ABI_FLAG} in
- abi_x86_64) arch=x86_64 ;;
- abi_x86_32) arch=ia32 ;;
-# abi_ppc_64) arch=ppc64 ;;
-# abi_ppc_32) arch=ppc32 ;;
- esac
-
- case "$(tc-getCXX)" in
- *clang*) comp="clang" ;;
- *g++*) comp="gcc" ;;
- *ic*c) comp="icc" ;;
- *) die "compiler $(tc-getCXX) not supported by build system" ;;
- esac
-
- CXX="$(tc-getCXX)" \
- CC="$(tc-getCC)" \
- AS="$(tc-getAS)" \
- arch=${arch} \
- CPLUS_FLAGS="${CXXFLAGS}" \
- emake compiler=${comp} work_dir="${BUILD_DIR}" tbb_root="${S}" $@
-}
-
-multilib_src_compile() {
- local_src_compile tbb tbbmalloc
-}
-
-multilib_src_test() {
- CXXFLAGS="${CXXFLAGS} -fabi-version=4" \
- local_src_compile -j1 test
-}
-
-multilib_src_install() {
- local bt
- local buildtypes
- if use debug ; then
- buildtypes="release debug"
- else
- buildtypes="release"
- fi
- for bt in ${buildtypes}; do
- cd "${BUILD_DIR}_${bt}" || die
- local l
- for l in $(find . -name lib\*$(get_libname \*)); do
- dolib.so ${l}
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%%.*}$(get_libname)
- done
- done
-
- cd "${BUILD_DIR}" || die
- insinto /usr/$(get_libdir)/pkgconfig
- doins *.pc
-}
-
-multilib_src_install_all() {
- doheader -r include/*
-
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc
- insinto /usr/share/doc/${PF}/examples
- doins -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/dev-cpp/tbb/tbb-2020.2.ebuild b/dev-cpp/tbb/tbb-2020.2.ebuild
deleted file mode 100644
index 3e132d1c71b7..000000000000
--- a/dev-cpp/tbb/tbb-2020.2.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal multilib toolchain-funcs
-
-PV1="$(ver_cut 1)"
-PV2="$(ver_cut 2)"
-MY_PV="${PV1}_U${PV2}"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="https://www.threadingbuildingblocks.org"
-SRC_URI="https://github.com/intel/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/oneTBB-${MY_PV}"
-
-DOCS=( CHANGES README README.md doc/Release_Notes.txt )
-
-PATCHES=( "${FILESDIR}"/${PN}-2020.1-makefile-debug.patch )
-
-src_prepare() {
- default
-
- find include -name \*.html -delete || die
-
- # Give it a soname on FreeBSD
- echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
- # Set proper versionning on FreeBSD
- sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
-
- use debug || sed -i -e '/_debug/d' Makefile
-}
-
-multilib_src_configure() {
- # pc files are for debian and fedora compatibility
- # some deps use them
- cat <<-EOF > ${PN}.pc.template
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Cflags: -I\${includedir}
- EOF
- cp ${PN}.pc.template ${PN}.pc || die
- cat <<-EOF >> ${PN}.pc
- Libs: -L\${libdir} -ltbb
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc.pc || die
- cat <<-EOF >> ${PN}malloc.pc
- Libs: -L\${libdir} -ltbbmalloc
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc_proxy.pc || die
- cat <<-EOF >> ${PN}malloc_proxy.pc
- Libs: -L\${libdir} -ltbbmalloc_proxy
- Libs.private: -lrt
- Requires: tbbmalloc
- EOF
-}
-
-local_src_compile() {
- cd "${S}"
-
- local comp arch
- local bt buildtypes
-
- case ${MULTILIB_ABI_FLAG} in
- abi_x86_64) arch=x86_64 ;;
- abi_x86_32) arch=ia32 ;;
-# abi_ppc_64) arch=ppc64 ;;
-# abi_ppc_32) arch=ppc32 ;;
- esac
-
- case "$(tc-getCXX)" in
- *clang*) comp="clang" ;;
- *g++*) comp="gcc" ;;
- *ic*c) comp="icc" ;;
- *) die "compiler $(tc-getCXX) not supported by build system" ;;
- esac
-
- if use debug ; then
- buildtypes="release debug"
- else
- buildtypes="release"
- fi
-
- for bt in ${buildtypes}; do
- CXX="$(tc-getCXX)" \
- CC="$(tc-getCC)" \
- AS="$(tc-getAS)" \
- arch=${arch} \
- CPLUS_FLAGS="${CXXFLAGS}" \
- emake compiler=${comp} work_dir="${BUILD_DIR}" tbb_root="${S}" cfg=${bt} $@
- done
-}
-
-multilib_src_compile() {
- local_src_compile tbb tbbmalloc
-}
-
-multilib_src_test() {
- local_src_compile test
-}
-
-multilib_src_install() {
- local bt
- local buildtypes
- if use debug ; then
- buildtypes="release debug"
- else
- buildtypes="release"
- fi
- for bt in ${buildtypes}; do
- cd "${BUILD_DIR}_${bt}" || die
- local l
- for l in $(find . -name lib\*$(get_libname \*)); do
- dolib.so ${l}
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%%.*}$(get_libname)
- done
- done
-
- cd "${BUILD_DIR}" || die
- insinto /usr/$(get_libdir)/pkgconfig
- doins *.pc
-}
-
-multilib_src_install_all() {
- doheader -r include/*
-
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc
- insinto /usr/share/doc/${PF}/examples
- doins -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}