summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/libcult
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/libcult')
-rw-r--r--dev-cpp/libcult/Manifest1
-rw-r--r--dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch57
-rw-r--r--dev-cpp/libcult/libcult-1.4.6-r1.ebuild86
-rw-r--r--dev-cpp/libcult/metadata.xml8
4 files changed, 152 insertions, 0 deletions
diff --git a/dev-cpp/libcult/Manifest b/dev-cpp/libcult/Manifest
new file mode 100644
index 000000000000..2be1c500e6f0
--- /dev/null
+++ b/dev-cpp/libcult/Manifest
@@ -0,0 +1 @@
+DIST libcult-1.4.6.tar.bz2 51036 SHA256 f1b51023880440d3e673bf9c3d2b034f1e16511b33ab006cd9f7d937246e48ac SHA512 4a3a3a2967bf8c8eaf47b028bbd475245d89ba746352b62a0e8fdc80ba912e90a928e2f4c863812b86e4c3881294d816a822c0f63a0aea2edc3f08d80365b3fd WHIRLPOOL 4bbf5e4ff7bef4c0c086b2c0be318c733b545f5910e72876ccf967d138df0d3de3b3c1f368147d64fd42828a7eecf1c3a5884c397f964df23dc0308ed8e13b43
diff --git a/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch b/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch
new file mode 100644
index 000000000000..f7b169a7cde2
--- /dev/null
+++ b/dev-cpp/libcult/files/1.4.6-fix-compilation-with-gcc-4.7.patch
@@ -0,0 +1,57 @@
+From 2ef8e0426baad35a3438f9497005c3e3391e23f0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tiziano=20M=C3=BCller?= <tm@dev-zero.ch>
+Date: Fri, 1 Jun 2012 10:12:33 +0200
+Subject: [PATCH 2/2] fix compilation with gcc-4.7
+
+---
+ cult/mm/evptr.hxx | 4 ++--
+ cult/mm/shptr.hxx | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/cult/mm/evptr.hxx b/cult/mm/evptr.hxx
+index 18f232c..ed0bd93 100644
+--- a/cult/mm/evptr.hxx
++++ b/cult/mm/evptr.hxx
+@@ -70,7 +70,7 @@ namespace Cult
+ Evptr&
+ operator= (Evptr const& ep)
+ {
+- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
++ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
+
+ return *this;
+ }
+@@ -79,7 +79,7 @@ namespace Cult
+ Evptr&
+ operator= (Evptr<Y> const& ep)
+ {
+- assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
++ this->assign (ep.cp_ ? ep.cp_ : ep.p_, ep.c_);
+
+ return *this;
+ }
+diff --git a/cult/mm/shptr.hxx b/cult/mm/shptr.hxx
+index a5e1257..6630b1c 100644
+--- a/cult/mm/shptr.hxx
++++ b/cult/mm/shptr.hxx
+@@ -45,7 +45,7 @@ namespace Cult
+ Shptr&
+ operator= (Shptr const& ap)
+ {
+- assign (ap);
++ this->assign (ap);
+ return *this;
+ }
+
+@@ -53,7 +53,7 @@ namespace Cult
+ Shptr&
+ operator= (Shptr<Y> const& ap)
+ {
+- assign (ap);
++ this->assign (ap);
+ return *this;
+ }
+
+--
+1.7.8.5
+
diff --git a/dev-cpp/libcult/libcult-1.4.6-r1.ebuild b/dev-cpp/libcult/libcult-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..aa97dc1e5963
--- /dev/null
+++ b/dev-cpp/libcult/libcult-1.4.6-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="A collection of C++ libraries"
+HOMEPAGE="http://kolpackov.net/projects/libcult/"
+SRC_URI="ftp://kolpackov.net/pub/projects/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="examples"
+
+DEPEND="dev-util/build:0.3
+ sys-devel/m4"
+RDEPEND=""
+
+src_prepare() {
+ # never build the examples
+ sed -i \
+ -e 's| $(out_base)/examples/[[:alnum:]\.]*||' \
+ -e '/examples\/makefile/d' \
+ makefile || die "sed failed"
+
+ epatch "${FILESDIR}/${PV}-fix-compilation-with-gcc-4.7.patch"
+}
+
+src_configure() {
+ mkdir -p build/{cxx/gnu,ld}
+
+ cat >> build/configuration-dynamic.make <<- EOF
+cult_dr := y
+cult_threads := y
+cult_network := y
+ EOF
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/ld/configuration-lib-dynamic.make <<- EOF
+ld_lib_type := shared
+ EOF
+
+ MAKEOPTS+=" verbose=1"
+}
+
+src_install() {
+ dolib.so cult/libcult.so
+
+ find cult -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf cult/arch
+
+ insinto /usr/include
+ doins -r cult
+
+ dodoc NEWS README documentation/[[:upper:]]*
+ dohtml -A xhtml -r documentation/*
+
+ if use examples ; then
+ find examples -name makefile -delete
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}
diff --git a/dev-cpp/libcult/metadata.xml b/dev-cpp/libcult/metadata.xml
new file mode 100644
index 000000000000..75dd2ca7d302
--- /dev/null
+++ b/dev-cpp/libcult/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>