summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-22 00:35:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-22 00:36:10 +0200
commit614cea5b7e5bd73013debda1ea192342ead88cb9 (patch)
tree7c97a93846878c4112ce51a765df9fd74a244349 /app-vim/python-mode
parentnet-dns/nsd: Removed old. (diff)
downloadgentoo-614cea5b7e5bd73013debda1ea192342ead88cb9.tar.gz
gentoo-614cea5b7e5bd73013debda1ea192342ead88cb9.tar.bz2
gentoo-614cea5b7e5bd73013debda1ea192342ead88cb9.zip
app-vim/python-mode: version bump.
Gentoo-Bug: https://bugs.gentoo.org/580676 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-vim/python-mode')
-rw-r--r--app-vim/python-mode/Manifest1
-rw-r--r--app-vim/python-mode/python-mode-0.9.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/python-mode/Manifest b/app-vim/python-mode/Manifest
index 015780cc231f..b2af0c502149 100644
--- a/app-vim/python-mode/Manifest
+++ b/app-vim/python-mode/Manifest
@@ -1 +1,2 @@
DIST python-mode-0.6.18.tar.gz 386846 SHA256 d46ff14b7ee639b698d1b0ae0e7ca0dcfa95a315ffb25e523ae720461f399c1d SHA512 0e3159a055304443c8b15590c424ac0f4a4303e343882ff91f01f5b959274931dea83969ab1dcd19ce95894c7da5be60699d51b852dc73165a99a271feec4e64 WHIRLPOOL 1a6114999c1b832335268dd7dd3e9ebfd48ce9e35cdc7058e4a1011d3ac0aeb36df85ab52599460e449c0ee645303aca17a8ecb44533a5d137a9b904c426b1da
+DIST python-mode-0.9.0.tar.gz 671985 SHA256 5a6c9ea3cd8e094318cc2acbbbf1f81e37b41a67d00eedcb1a6968f8524c8e5e SHA512 03aef010a95241abf9605ca334d95a2c0b917c61aea23f794e574acd56ba5d958032975d17d1af40a5edccd90f0172783a26fc301d799fd619bfd263da685161 WHIRLPOOL 1d8f9a3a74cc6ba4ab45267dfa8366e78e313a6b8a38f66a1b7c70e0e226b1f79b5b8a162cd841666ddbf663dbbd7a9df847d2b428b80a03ecb39126d375f1d5
diff --git a/app-vim/python-mode/python-mode-0.9.0.ebuild b/app-vim/python-mode/python-mode-0.9.0.ebuild
new file mode 100644
index 000000000000..1992f3c0658f
--- /dev/null
+++ b/app-vim/python-mode/python-mode-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIM_PLUGIN_MESSAGES="filetype"
+VIM_PLUGIN_HELPFILES="PythonModeCommands"
+VIM_PLUGIN_HELPURI="https://github.com/klen/python-mode"
+
+inherit vim-plugin eutils
+
+DESCRIPTION="Provide python code looking for bugs, refactoring and other useful things"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3770 https://github.com/klen/python-mode"
+SRC_URI="https://github.com/klen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/rope
+ dev-python/astng
+ dev-python/pylint
+ dev-python/pyflakes
+ dev-python/autopep8
+ dev-python/ropemode"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
+ -i autoload/pymode.vim || die # use custom path
+}
+
+src_install() {
+ vim-plugin_src_install
+ insinto usr/share/${PN}
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+}