summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:08:10 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:38 +0200
commit1da50990f8d6cca06e40197c77353028700652aa (patch)
tree8ae44db682f0b1badeab0c0e368b29adcee03523 /app-vim/gitv
parentapp-vim/gitlog: remove live ebuild (diff)
downloadgentoo-1da50990f8d6cca06e40197c77353028700652aa.tar.gz
gentoo-1da50990f8d6cca06e40197c77353028700652aa.tar.bz2
gentoo-1da50990f8d6cca06e40197c77353028700652aa.zip
app-vim/gitv: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/gitv')
-rw-r--r--app-vim/gitv/gitv-1.3.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/gitv/gitv-1.3.1-r1.ebuild b/app-vim/gitv/gitv-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..967936be8c8d
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86 ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="
+ dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags || die
+ rm -r img || die
+ default
+}