summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 12:10:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:10:57 +0200
commit588700c230558e84552c6c5400fadb9ed2403d3b (patch)
tree0b02f93d67fd95522d2f3c24a8bc907b794cb440 /app-portage
parentapp-misc/tmuxp: Enable py3.9 (diff)
downloadgentoo-588700c230558e84552c6c5400fadb9ed2403d3b.tar.gz
gentoo-588700c230558e84552c6c5400fadb9ed2403d3b.tar.bz2
gentoo-588700c230558e84552c6c5400fadb9ed2403d3b.zip
app-portage/g-sorcery: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-sorcery/g-sorcery-0.2.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-portage/g-sorcery/g-sorcery-0.2.2.ebuild b/app-portage/g-sorcery/g-sorcery-0.2.2.ebuild
index e05a407dfc0e..368e36a04f05 100644
--- a/app-portage/g-sorcery/g-sorcery-0.2.2.ebuild
+++ b/app-portage/g-sorcery/g-sorcery-0.2.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 prefix
@@ -19,10 +19,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="bson git test"
RESTRICT="!test? ( test )"
-DEPEND="bson? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+BDEPEND="
+ bson? ( dev-python/pymongo[${PYTHON_USEDEP}] )
git? ( dev-vcs/git )
sys-apps/portage[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${BDEPEND}"
PDEPEND=">=app-portage/layman-2.2.0[g-sorcery(-),${PYTHON_USEDEP}]"
src_prepare() {
@@ -31,7 +32,7 @@ src_prepare() {
}
python_test() {
- PYTHONPATH="." "${PYTHON}" scripts/run_tests.py
+ PYTHONPATH="." "${PYTHON}" scripts/run_tests.py || die
}
python_install_all() {