summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Brandt <poncho@spahan.ch>2022-01-15 21:35:17 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-02-11 16:56:45 +0200
commit7039588a8eebff34a39e17fe7cb10c9fd323c39f (patch)
treef0b05b3370cc535c4497413383f009974b458b5f /app-office
parentdev-util/gengetopt: add missing BDEPEND (diff)
downloadgentoo-7039588a8eebff34a39e17fe7cb10c9fd323c39f.tar.gz
gentoo-7039588a8eebff34a39e17fe7cb10c9fd323c39f.tar.bz2
gentoo-7039588a8eebff34a39e17fe7cb10c9fd323c39f.zip
app-office/homebank: version bump to 5.5.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Daniel Brandt <poncho@spahan.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/homebank/Manifest1
-rw-r--r--app-office/homebank/homebank-5.5.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
index 575700ed6602..41b593da5a20 100644
--- a/app-office/homebank/Manifest
+++ b/app-office/homebank/Manifest
@@ -1,2 +1,3 @@
DIST homebank-5.5.1.tar.gz 3054854 BLAKE2B 8cfab126069b3404223645e3f37038db44040d873c2edbc06a5286ca936584016044d6e8dd4444166910b4c5a87874db5bdad43452aca2aa8f96ba0e7f648fbe SHA512 a13eccf92882d5bfe6b09a99d6c805337f68d5169c58615b750bf5994abd4df0709065e12d4cdc8eb0c80f758f602548b0279dc7eb089f7417f5da8fd1955626
DIST homebank-5.5.2.tar.gz 3056800 BLAKE2B c2c00214cb1311271b6c38ee8643ed1f6c6701ca07222fc60c6eb7d8c2fb4aecaacc188917825e386c13e908d22038602d7293f9d913b2c76d10956b5fbd3636 SHA512 c4279bb0f0d0ab58024c1d32148d987cc61c83ca77d8f523488a9c2dde9009469bce8291e8e90d5fdeae631813ec7556a5b4db7c709624f178fdee165feaa3ef
+DIST homebank-5.5.4.tar.gz 3089097 BLAKE2B 3b73ca8a016a02c5050bed4d702cb2e71ed34182a2cc41a043e4af8053acc21df738bc91d564cb51b9e08aaa4b60156ea824a38ebd21eea00266f55951d23e59 SHA512 ae85fcc46ef8428a0dca865ec0b51532f4ada28a2515873f00802ac8894cc9ad1c93be64a587a5e119efe3c61436d7aabd1f90ee559af047ddf65c3b59bc066d
diff --git a/app-office/homebank/homebank-5.5.4.ebuild b/app-office/homebank/homebank-5.5.4.ebuild
new file mode 100644
index 000000000000..9323efee4b50
--- /dev/null
+++ b/app-office/homebank/homebank-5.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.39
+ >=net-libs/libsoup-2.26:2.4
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ default
+
+ # avoid using eautoreconf
+ sed -i -e 's|\$(datadir)/appdata|\$(datadir)/metainfo|' data/Makefile.{am,in} || die
+}
+
+src_configure() {
+ econf $(use_with ofx)
+}