summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-13 01:25:20 +0000
committerMatt Turner <mattst88@gentoo.org>2021-03-24 12:06:55 -0400
commite44a479a30ddad1e1617ea492714a7c3a56e6db8 (patch)
treeb4291019190c6fe6d5600746a1d415970f607f2e /app-misc
parentapp-backup/fsarchiver: default-enable zstd support (diff)
downloadgentoo-e44a479a30ddad1e1617ea492714a7c3a56e6db8.tar.gz
gentoo-e44a479a30ddad1e1617ea492714a7c3a56e6db8.tar.bz2
gentoo-e44a479a30ddad1e1617ea492714a7c3a56e6db8.zip
app-misc/mouseremote: revbump for d-m-i
Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19438 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mouseremote/files/mouseremote.start-r128
-rw-r--r--app-misc/mouseremote/mouseremote-0.90-r3.ebuild70
2 files changed, 98 insertions, 0 deletions
diff --git a/app-misc/mouseremote/files/mouseremote.start-r1 b/app-misc/mouseremote/files/mouseremote.start-r1
new file mode 100644
index 000000000000..fd6aa9c854f1
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote.start-r1
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use modules logger
+ before display-manager
+}
+
+checkconfig() {
+ [ -z "$DEV" ] || [ -z "$DRV" ] || return 0
+ eerror "You need to setup DEV and DRV in /etc/conf.d/mouseremote first"
+ return 1
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting X10 MouseRemote Server"
+ /usr/sbin/multimoused -${DRV} ${DEV} 2> /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping X10 MouseRemote Server"
+ kill $(cat /var/lock/MultiMouse.pid)
+ eend ${?} "Failed to stop MouseRemote Server"
+}
diff --git a/app-misc/mouseremote/mouseremote-0.90-r3.ebuild b/app-misc/mouseremote/mouseremote-0.90-r3.ebuild
new file mode 100644
index 000000000000..a64b724d8b6e
--- /dev/null
+++ b/app-misc/mouseremote/mouseremote-0.90-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="X10 MouseRemote"
+HOMEPAGE="http://www4.pair.com/gribnif/ha/"
+SRC_URI="http://www4.pair.com/gribnif/ha/MouseRemote.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/perl-Time-HiRes"
+
+S="${WORKDIR}/MouseRemote"
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${P}-makefile.diff
+ eapply "${FILESDIR}"/${P}-gentoo.diff
+ eapply -p0 "${FILESDIR}"/${P}-fix-warnings.diff
+
+ eapply_user
+}
+
+src_compile() {
+ cd MultiMouse && emake \
+ CC=$(tc-getCC) \
+ PREFIX=/usr \
+ LOCKDIR=/var/lock \
+ JMANDIR=/usr/share/man/ja_JP.ujis
+}
+
+src_install() {
+ dobin MultiMouse/multimouse
+ dosbin MultiMouse/multimoused
+
+ dodoc README MultiMouse/README.jis MultiMouse/README.newstuff
+ newdoc MultiMouse/README README.MultiMouse
+ newdoc client/MouseRemote.conf MouseRemote.conf.dist
+ newdoc client/MouseRemote.pl MouseRemote.pl.dist
+ newdoc client/MouseRemoteKeys.pl MouseRemoteKeys.pl.dist
+
+ newinitd "${FILESDIR}"/mouseremote.start-r1 mouseremote
+ newconfd "${FILESDIR}"/mouseremote.conf mouseremote
+}
+
+pkg_postinst() {
+ [ -e /dev/mumse ] || mkfifo "${ROOT}"/dev/mumse
+ [ -e /dev/x10fifo ] || mkfifo "${ROOT}"/dev/x10fifo
+
+ elog "To use the mouse function in X, add the following to your XF86Config"
+ elog "Section \"InputDevice\""
+ elog " Identifier \"MouseREM\""
+ elog " Driver \"mouse\""
+ elog " Option \"Protocol\" \"MouseSystems\""
+ elog " Option \"Device\" \"/dev/mumse\""
+ elog "EndSection"
+ elog
+ elog "Don't forget to add the new device to the section \"ServerLayout\""
+ elog "like: InputDevice \"MouseREM\" \"SendCoreEvents\""
+ elog
+ elog "Enable the daemon with \"rc-update add mouseremote default\"."
+ elog
+ elog "Configure the daemon is run in /etc/conf.d/mouseremote."
+ elog
+ elog "See /usr/share/doc/${PF} on how to configure the buttons."
+}