summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/socnetv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/socnetv')
-rw-r--r--app-misc/socnetv/Manifest1
-rw-r--r--app-misc/socnetv/metadata.xml19
-rw-r--r--app-misc/socnetv/socnetv-0.90.ebuild47
3 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/socnetv/Manifest b/app-misc/socnetv/Manifest
new file mode 100644
index 000000000000..9a1c2a8032e8
--- /dev/null
+++ b/app-misc/socnetv/Manifest
@@ -0,0 +1 @@
+DIST SocNetV-0.90.tar.gz 371285 SHA256 044988db0cb068c61f8310fa6e51fe2db098cc9a040694b69cab495066b35744 SHA512 a2f6972486d5437977f76539ae00fa6400d979285926398629209199d2fb8b8758c1fd18dc88d89e19865072b9749d5183151c93b6714f802589b0fe10ea7791 WHIRLPOOL bec2654fb2c2141d55e4dee4ea41880d451de8f30d23292abf064df3fec691a3df15a2dcd76961685b5ed0a39e4b9ca979227e2be3d120cbd8865c24d7c4ea7b
diff --git a/app-misc/socnetv/metadata.xml b/app-misc/socnetv/metadata.xml
new file mode 100644
index 000000000000..0580520cf4be
--- /dev/null
+++ b/app-misc/socnetv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+ Social Networks Visualizer (SocNetV) is a flexible and user-friendly tool for
+ the analysis and visualization of Social Networks. It lets you construct networks
+ (mathematical graphs) with a few clicks on a virtual canvas or load networks of
+ various formats (GraphViz, GraphML, Adjacency, Pajek, UCINET, etc) and modify them
+ to suit your needs. SocNetV also offers a built-in web crawler, allowing you to
+ automatically create networks from all links found in a given initial URL.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">socnetv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/socnetv/socnetv-0.90.ebuild b/app-misc/socnetv/socnetv-0.90.ebuild
new file mode 100644
index 000000000000..ce6c2dd891a8
--- /dev/null
+++ b/app-misc/socnetv/socnetv-0.90.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils qt4-r2 toolchain-funcs
+
+MY_PN="SocNetV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt Social Network Visualizer"
+HOMEPAGE="http://socnetv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/socnetv/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt4-r2_src_prepare
+ sed -i "s/@make/@+make/" Makefile.in \
+ || die "Fix parallel build"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${LDFLAGS} ${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin socnetv
+ doicon src/images/socnetv.png
+ make_desktop_entry ${PN} SocNetV ${PN} 'Science'
+ insinto /usr/share/${PN}/examples
+ doins nets/*
+ dodoc AUTHORS ChangeLog README TODO
+ if use doc; then
+ dohtml -r "${S}"/manual/*
+ fi
+ doman "${S}/man/${PN}.1.gz"
+}