summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-17 12:54:52 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-17 12:55:10 -0600
commit6b8a2da22d9ecf1c5b7a338fd08a9616f903f708 (patch)
treee0877cc960e214f5882777b694cda7e91128b1e2 /app-metrics/prometheus
parentdev-tcltk/tkzinc: fix incomp pointer conversion (diff)
downloadgentoo-6b8a2da22d9ecf1c5b7a338fd08a9616f903f708.tar.gz
gentoo-6b8a2da22d9ecf1c5b7a338fd08a9616f903f708.tar.bz2
gentoo-6b8a2da22d9ecf1c5b7a338fd08a9616f903f708.zip
app-metrics/prometheus: add 2.41.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics/prometheus')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.41.0.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 8a617154e4f7..88cb8cc4ca83 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -4,3 +4,6 @@ DIST prometheus-2.37.5.tar.gz 6048663 BLAKE2B c3dfaee0093f50ce5a9bfe7fd27a21d775
DIST prometheus-2.40.4-assets.tar.xz 45585656 BLAKE2B b187b6683c778b5e9746f1f9695e03303cf5481387bb0517afee56685edc62bbb82c515f8dfeeafeb09a74b57b540da49d1936c7ec74b3013adc7afc8f07ea5f SHA512 8a229504b66bac0ef2fa7a9caafc93fdf3e1c9aa33e892219e57a21b44355515e69a232db98ce4f5664fb98cb37cfb3ec619eb2a3ccf662474544dfdbbba580c
DIST prometheus-2.40.4-deps.tar.xz 253189332 BLAKE2B ca2c2f3e111897ac47d71acc3046230608134c854f7af7a4c5ec1fe75dfbb61c6bf278fe00f77ecf65113b72cbd67171634a0fbf57ad09e3349a7e8f45791e33 SHA512 29bf419e45d389805b1f37256cb8a9ce9cc6cb88b3cd4a7a1681121f24158cce7aa5a949554f5344409ba4f683976866bfc766666e2a0a247996c135d2068b6f
DIST prometheus-2.40.4.tar.gz 6156657 BLAKE2B a522b31516f5e26475afa2d59a7074b7deb2a70ffbf7cce6e3951bfeacc6dae6d8f59d1b1b591d1c59c0ac9839bc691ce315d55f7fe0a45be573e124f651764b SHA512 9b46f9f3b986929bdfe365645e43c0a3c2073b920e59cc512287f866506d7db7b83ffb2dbe24d1835fccc1b2cc781be7a373da5fb58c04521648981b19e81737
+DIST prometheus-2.41.0-assets.tar.xz 45792212 BLAKE2B 79e494a983d1e666b2e706532c2bd16562382b458132af2c8f26ab684097bd70384e1a11d0926662592b0d3133cab4435b16d1e2d7f1cd3a3b237831cf762dc4 SHA512 a35ec5b31fa05f2f044b9b843095cf68913664f88a4b9f64479ae2392682a7a7c8cf5e7239340ff260bf151c92d06929284174371cac072d32355103d9257131
+DIST prometheus-2.41.0-deps.tar.xz 254253988 BLAKE2B 8ba4697b53a99660d9191097fb734c1024b8b9a437c18d9eaf0a10e7e065364e34eb419751fce253188aa3ec6714ab1231ed85d11469dd76fe1eb76e4cdd4360 SHA512 87f591c93bec487210e9adf4c486f96fc02b708f923b4dd01f4e264a800190733f36718170f5da647e5aef4839214809e850ffac3cad17cb80957adaa80ef5a9
+DIST prometheus-2.41.0.tar.gz 6184846 BLAKE2B 525fca8b006b0edf9c6c3e71120b4c11af1e08966108c21ab4897501f64d454b3ac2ac7c5f986485d2c1c2d2186f3dc131ad6df1499f5006fa68473de7fc0aed SHA512 87076421a9c641c3553fe039a5de6e6c0a63f44869895bc0741a446bd150a59ca77eaa4080bac61ecbc3c4bf378ea79fabe1e640710793cd8c83a20ba7e4a5e1
diff --git a/app-metrics/prometheus/prometheus-2.41.0.ebuild b/app-metrics/prometheus/prometheus-2.41.0.ebuild
new file mode 100644
index 000000000000..c22eb2ffd1c7
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.41.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=414d31aee6586a5f29e755ae059b7d7131f1c6c8
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -n "${WORKDIR}"/web/ui web || die
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}