summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Willem Fernhout <hfern@fernhout.info>2021-04-05 11:23:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-13 10:28:32 +0300
commitd32a2fc7c493af5d367304ead0c204e5590751e1 (patch)
tree1dc77abd63daca7ce918f0fe59c750c7e01d31b9 /app-laptop/thinkfan
parentdev-python/urwidtrees: Fix mock dependency bug #770391 (diff)
downloadgentoo-d32a2fc7c493af5d367304ead0c204e5590751e1.tar.gz
gentoo-d32a2fc7c493af5d367304ead0c204e5590751e1.tar.bz2
gentoo-d32a2fc7c493af5d367304ead0c204e5590751e1.zip
app-laptop/thinkfan: version bump to 1.2.1
Closes: https://bugs.gentoo.org/733792 Closes: https://bugs.gentoo.org/715986 Tested-by: David Duchesne <aether@disroot.org> Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info> Closes: https://github.com/gentoo/gentoo/pull/20263 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop/thinkfan')
-rw-r--r--app-laptop/thinkfan/Manifest1
-rw-r--r--app-laptop/thinkfan/metadata.xml9
-rw-r--r--app-laptop/thinkfan/thinkfan-1.2.1.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
index e3c97f7e9816..783936bff988 100644
--- a/app-laptop/thinkfan/Manifest
+++ b/app-laptop/thinkfan/Manifest
@@ -1 +1,2 @@
DIST thinkfan-1.0.2.tar.gz 77653 BLAKE2B 1b40553380f9b873883f0dc587665f24cd2e07de7a7e743cb9f99a3282f380da2258265a612b1c97d2945fed31aee0d6cbc30ea2a18c0b212e877e7635eda336 SHA512 d9133538096a7c5757f599adfebc8217aa7334a102573d6757f03b5c012a09d600be923930fd9d62f4afa591f5eb7a70a1c328004bddef85494d1a7ce56b648f
+DIST thinkfan-1.2.1.tar.gz 84253 BLAKE2B 5a816b8cadbc72424384966b0bc6bcf17070eec703584c348bc28cf8ee59e4d67a56d351f0c1d9d55328326b21134f0158bf976f86336bb5d59b81c137b96c83 SHA512 27db9f54c26a85093ff7b9f8a0e26f679e413489f608b561b819a702fd077a33e62197e41a1f1f4495c66daa1ac70603c063e6ac4cdd09d13f4005f73685152d
diff --git a/app-laptop/thinkfan/metadata.xml b/app-laptop/thinkfan/metadata.xml
index 134e69ff9e5d..8f49761db66c 100644
--- a/app-laptop/thinkfan/metadata.xml
+++ b/app-laptop/thinkfan/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>hfern@fernhout.info</email>
+ <name>Johannes Willem Fernhout</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<use>
<flag name="atasmart">include libatasmart support to get disc temperature</flag>
<flag name="nvidia">allow thinkfan to read GPU temperature from the proprietary nVidia driver</flag>
diff --git a/app-laptop/thinkfan/thinkfan-1.2.1.ebuild b/app-laptop/thinkfan/thinkfan-1.2.1.ebuild
new file mode 100644
index 000000000000..fb111f2a2561
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+DOC_CONTENTS="
+ Please read the documentation and copy an appropriate
+ file to /etc/thinkfan.conf.
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}