summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-01-30 00:33:10 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-01-30 00:33:27 -0500
commit4469bdbf74cebf43c949f218a202caf0f5b70f99 (patch)
tree43792e470af90dafb802140418766f5de832ae6d /app-emulation/wine
parentphp-ext-source-r2: Add phpdbg SAPI to the default list (diff)
downloadgentoo-4469bdbf74cebf43c949f218a202caf0f5b70f99.tar.gz
gentoo-4469bdbf74cebf43c949f218a202caf0f5b70f99.tar.bz2
gentoo-4469bdbf74cebf43c949f218a202caf0f5b70f99.zip
app-emulation/wine: Check SHAs for staging compat, bug #572522
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/wine-9999.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 4c1b6f446af0..b44030bba0e6 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -204,9 +204,21 @@ src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
if use staging; then
+ local WINE_COMMIT=${EGIT_VERSION}
+
EGIT_REPO_URI=${STAGING_EGIT_REPO_URI}
unset ${PN}_LIVE_REPO;
+ unset EGIT_COMMIT;
+
EGIT_CHECKOUT_DIR=${STAGING_DIR} git-r3_src_unpack
+
+ local STAGING_COMMIT=$("${STAGING_DIR}/patches/patchinstall.sh" --upstream-commit) || die
+
+ if [[ "${WINE_COMMIT}" != "${STAGING_COMMIT}" ]]; then
+ einfo "The current Staging patchset is not guaranteed to apply on this WINE commit."
+ einfo "If src_prepare fails, try emerging with the env var EGIT_COMMIT."
+ einfo "Example: EGIT_COMMIT=${STAGING_COMMIT} emerge -1 wine"
+ fi
fi
else
unpack ${P}.tar.bz2