summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-22 18:23:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-22 18:24:00 +0100
commit58f5f8585fb5482e5b42de36a3730552ed003859 (patch)
treeac060ad1cf6c6e6fb914d0923713dc7f83ee344b /app-emulation/dosemu
parentmedia-video/streamdeck-ui: fix deps (diff)
downloadgentoo-58f5f8585fb5482e5b42de36a3730552ed003859.tar.gz
gentoo-58f5f8585fb5482e5b42de36a3730552ed003859.tar.bz2
gentoo-58f5f8585fb5482e5b42de36a3730552ed003859.zip
app-emulation/dosemu: don't use 'as' to test assembler, bug #722176
Instead of probing for 'as' use '$CC'. Build system uses '$CC' to compile '.S' files. Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/722176 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-emulation/dosemu')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild4
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-as.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
index f25169144560..c7771af9cd8f 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2002-2019 Gentoo Authors
+# Copyright 2002-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -55,6 +55,7 @@ PATCHES=(
"${FILESDIR}"/${P}-ia16-ldflags.patch
"${FILESDIR}"/${P}-fix-inline.patch
"${FILESDIR}"/${P}-lto.patch
+ "${FILESDIR}"/${P}-as.patch
)
src_prepare() {
@@ -97,6 +98,7 @@ src_configure() {
}
src_compile() {
+ # src/makefile.common is fritten manually, uses AR=ar
emake AR=$(tc-getAR)
}
diff --git a/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-as.patch b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-as.patch
new file mode 100644
index 000000000000..2db3048be391
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-as.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -503,8 +503,7 @@ dnl CPU emulator
+ AC_MSG_NOTICE(Compiling for native x86...);
+ fi
+
+-
+-if ! echo '.code16;.text;addr32 pushw 4(%esp)' | as -o dummy.o >/dev/null 2>&1; then
++if ! echo '.code16;.text;addr32 pushw 4(%esp)' | $CC -c -x assembler -o dummy.o - >/dev/null 2>&1; then
+ echo ''
+ echo '*** error:'
+ echo '*** Your system has no complete code16 functional gas,'