summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-11 08:42:29 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-11 08:44:02 +0200
commit1cf5b2461c512ac556571f15968a826b5aa130b6 (patch)
tree9bf83794684f9350aa319e2a40494764a3c4a94a /app-editors/emacs
parentapp-misc/rpick: Stabilize 0.8.9 x86, #837674 (diff)
downloadgentoo-1cf5b2461c512ac556571f15968a826b5aa130b6.tar.gz
gentoo-1cf5b2461c512ac556571f15968a826b5aa130b6.tar.bz2
gentoo-1cf5b2461c512ac556571f15968a826b5aa130b6.zip
app-editors/emacs: Enable jit workaround also with distcc
Thanks to Maciej S. Szmigiero for the fix. Closes: https://bugs.gentoo.org/837506 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-28.1.9999.ebuild4
-rw-r--r--app-editors/emacs/emacs-28.1.ebuild4
-rw-r--r--app-editors/emacs/emacs-29.0.9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/emacs/emacs-28.1.9999.ebuild b/app-editors/emacs/emacs-28.1.9999.ebuild
index 9130393b32fa..4c1a544cb35f 100644
--- a/app-editors/emacs/emacs-28.1.9999.ebuild
+++ b/app-editors/emacs/emacs-28.1.9999.ebuild
@@ -153,9 +153,9 @@ src_prepare() {
# for live ebuilds FULL_VERSION doesn't exist in global scope
QA_FLAGS_IGNORED="usr/$(get_libdir)/emacs/${FULL_VERSION}/native-lisp/.*"
- # gccjit doesn't play well with ccache #801580
+ # gccjit doesn't play well with ccache or distcc #801580
# For now, work around the problem with an explicit LIBRARY_PATH
- has ccache ${FEATURES} && tc-is-gcc \
+ has ccache ${FEATURES} || has distcc ${FEATURES} && tc-is-gcc \
&& export LIBRARY_PATH=$("$(tc-getCC)" -print-search-dirs \
| sed -n '/^libraries:/{s:^[^/]*::;p}')
fi
diff --git a/app-editors/emacs/emacs-28.1.ebuild b/app-editors/emacs/emacs-28.1.ebuild
index 85368109ec31..135fab7e795b 100644
--- a/app-editors/emacs/emacs-28.1.ebuild
+++ b/app-editors/emacs/emacs-28.1.ebuild
@@ -153,9 +153,9 @@ src_prepare() {
# for live ebuilds FULL_VERSION doesn't exist in global scope
QA_FLAGS_IGNORED="usr/$(get_libdir)/emacs/${FULL_VERSION}/native-lisp/.*"
- # gccjit doesn't play well with ccache #801580
+ # gccjit doesn't play well with ccache or distcc #801580
# For now, work around the problem with an explicit LIBRARY_PATH
- has ccache ${FEATURES} && tc-is-gcc \
+ has ccache ${FEATURES} || has distcc ${FEATURES} && tc-is-gcc \
&& export LIBRARY_PATH=$("$(tc-getCC)" -print-search-dirs \
| sed -n '/^libraries:/{s:^[^/]*::;p}')
fi
diff --git a/app-editors/emacs/emacs-29.0.9999.ebuild b/app-editors/emacs/emacs-29.0.9999.ebuild
index 41b8333bd0ab..0de26a675244 100644
--- a/app-editors/emacs/emacs-29.0.9999.ebuild
+++ b/app-editors/emacs/emacs-29.0.9999.ebuild
@@ -175,9 +175,9 @@ src_prepare() {
# for live ebuilds FULL_VERSION doesn't exist in global scope
QA_FLAGS_IGNORED="usr/$(get_libdir)/emacs/${FULL_VERSION}/native-lisp/.*"
- # gccjit doesn't play well with ccache #801580
+ # gccjit doesn't play well with ccache or distcc #801580
# For now, work around the problem with an explicit LIBRARY_PATH
- has ccache ${FEATURES} && tc-is-gcc \
+ has ccache ${FEATURES} || has distcc ${FEATURES} && tc-is-gcc \
&& export LIBRARY_PATH=$("$(tc-getCC)" -print-search-dirs \
| sed -n '/^libraries:/{s:^[^/]*::;p}')
fi