summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/asekey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/asekey')
-rw-r--r--app-crypt/asekey/Manifest1
-rw-r--r--app-crypt/asekey/asekey-3.7.ebuild36
-rw-r--r--app-crypt/asekey/files/asekey-3.7-bundle.patch24
-rw-r--r--app-crypt/asekey/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/asekey/Manifest b/app-crypt/asekey/Manifest
new file mode 100644
index 000000000000..4f8d7a57444c
--- /dev/null
+++ b/app-crypt/asekey/Manifest
@@ -0,0 +1 @@
+DIST asekey-3.7.tar.bz2 33304 SHA256 5561c54d0629489fcf689ebacc4f8bc3b6305b02ef5675a5d9669dc6669fd6e7 SHA512 29a01f8250d5fb26a4ba2aca562211cadf403c9e986f9fa6930faf477c374e13095c025b2917e6e837cbe8d83f3a3e023a527598b151ef1c704247c7e7c40647 WHIRLPOOL 3e38ef00b20abca33a980b0ffe05db9469945a574b3e71f9c4dbbea87a41857b9a0a69db748698ed368dcb5e34989c6b917b3c39c2e55f4a26e9923cafbc5149
diff --git a/app-crypt/asekey/asekey-3.7.ebuild b/app-crypt/asekey/asekey-3.7.ebuild
new file mode 100644
index 000000000000..d546b09f4e8b
--- /dev/null
+++ b/app-crypt/asekey/asekey-3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils udev
+
+DESCRIPTION="ASEKey USB SIM Card Reader"
+HOMEPAGE="http://www.athena-scs.com/"
+SRC_URI="${HOMEPAGE}/docs/reader-drivers/${PN}-${PV/./-}-tar.bz2 -> ${P}.tar.bz2"
+LICENSE="BSD LGPL-2.1"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-apps/pcsc-lite[udev]"
+RDEPEND="${RDEPEND}
+ virtual/libusb:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-bundle.patch"
+ sed -i -e 's/GROUP="pcscd"/ENV{PCSCD}="1"/' "92_pcscd_${PN}.rules" || die
+}
+
+src_configure() {
+ econf --with-udev-rules-dir="$(get_udevdir)/rules.d"
+}
+
+src_install() {
+ default
+ dodoc ChangeLog README
+}
diff --git a/app-crypt/asekey/files/asekey-3.7-bundle.patch b/app-crypt/asekey/files/asekey-3.7-bundle.patch
new file mode 100644
index 000000000000..fd233001718e
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-bundle.patch
@@ -0,0 +1,24 @@
+diff --git a/Info.plist b/Info.plist
+index ed473da..9d59815 100644
+--- a/Info.plist
++++ b/Info.plist
+@@ -14,6 +14,7 @@
+ <string>ASEKey</string>
+ <string>ASEKey</string>
+ </array>
++ <key>CFBundleExecutable</key>
+ <array>
+ <string>libASEKey.so</string>
+ <string>libASEKey.so</string>
+diff --git a/Makefile b/Makefile
+index 285ceff..1b06fd1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,6 @@ clean:
+
+ install: all
+ install -c -d "${DRIVER_DIR}/Contents/${KERNEL_NAME}"
+- install -c -m 0755 libASEKey.so "${DRIVER_DIR}"
+ install -c -m 0644 Info.plist "${DRIVER_DIR}/Contents/"
+ install -c -m 0755 libASEKey.so "${DRIVER_DIR}/Contents/${KERNEL_NAME}"
+ install -c -d "${UDEV_DIR}"
diff --git a/app-crypt/asekey/metadata.xml b/app-crypt/asekey/metadata.xml
new file mode 100644
index 000000000000..b02ffbb5d348
--- /dev/null
+++ b/app-crypt/asekey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+</pkgmetadata>