summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-12 01:12:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-12 01:12:38 +0200
commitab7583dd3c2873e76cc54c09b0e16b54123f4016 (patch)
treeeb82362bc22c63d2132c732a60fa5d26b67b4a80 /app-containers
parentapp-containers/earthly: drop old 0.8.8 (diff)
downloadgentoo-ab7583dd3c2873e76cc54c09b0e16b54123f4016.tar.gz
gentoo-ab7583dd3c2873e76cc54c09b0e16b54123f4016.tar.bz2
gentoo-ab7583dd3c2873e76cc54c09b0e16b54123f4016.zip
app-containers/earthly: bump to 0.8.14
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.14.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 04b37ba05285..0ac42410070b 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -6,5 +6,7 @@ DIST earthly-0.8.12-deps.tar.xz 163755972 BLAKE2B 6d5e7e2d157b54818bebca7cc0b57b
DIST earthly-0.8.12.tar.gz 8090651 BLAKE2B ce916a50b23bc5567b4174ad88a5a52b9c728b4ee215239f46680fe5574f0cabe353d5a336e395f7eec42c86a726bb0d0da4b5204dcc9654c76a8a8cd3366fb4 SHA512 7cc62cc3af6aef039f8059e04564a181dd9b497cb51f15b6a49f2aad4a975147aa30d9109eb1c33cfc74a6f354eae77904d5c0e15e63172cb7ee20874b9bc05e
DIST earthly-0.8.13-deps.tar.xz 163750220 BLAKE2B 995ed748f99b7d4c4ca90cdd1964c295270963e55462bfa3bdd830209a90303d67c91fed66e7d52984993ef58b1d060e140694fdc8931ca2181dd88701d8f6dd SHA512 ab3ee4fef9a87dab9009ffd4e31d00a256c8ad88096c8573a5a2fb782079392415752024821240da60549d260c9dcfe3d6f1457fb3fbc8cc8a1f2602bb875aee
DIST earthly-0.8.13.tar.gz 8082676 BLAKE2B cf6d5c6d397951a60302e5492ad219d3d673cce9bf2e06696a3cd8719dcf1d755644413171c7db1b27c60d6cbe0d85facf2d6a5d150c26dc5530c07d1255b742 SHA512 f3abd814c0c57f485a37c83e322d9a8478236ae4220baf455330a6a28d98a8cb7806fb4cee9525c9b27c51bc0ed8780872f51ece7194059658defd54cce1a6b5
+DIST earthly-0.8.14-deps.tar.xz 163777848 BLAKE2B 0615db6d874a0d490666df6517581763315c44a67662d1c8c630d59983849c3a1c10bdee4d626f9ded02a58f7eb037e24cca6b22dfc7eadf79d4e735a33306c5 SHA512 ac062ae77e98ec36f9bba1a73430080d2f2c7bed3ad8c48af8bb1da4a6f006a4285fca8f4d85363652ec3db9df78e76befdfc838971684d704512d795d672414
+DIST earthly-0.8.14.tar.gz 8079338 BLAKE2B c3da74c39b77f671656ba51f7e8a82b77476650e986e5665e1df86fd1674e808b79edcc0b8f616891b6749ec034de45268fb48df519c5fdf54c1e3e583eab5a6 SHA512 566e6bdd6f026baa99bad33128e3a843ef20dacc15efdccaf19af648440c8ee7b445bed80f33102b9fc419d211dc6dea38a66655247549f1eaf17837c6687105
DIST earthly-0.8.9-deps.tar.zst 180210180 BLAKE2B 8d48677c9dac4571efadb41c882520ba6f92bfc4a6f36ae55f6ce54c258f16dbd693412d1a25b4467d078c2b9b039b96d934236c3a071f1f64040b2da5a3d848 SHA512 f504567855830d8027d830372f8e365b8f9893d3625b94b2e91294985f65be3d276cdceba9913ef37a6e1a45debcd8fb393e6ea0d16615c06a188862b33d8a1d
DIST earthly-0.8.9.tar.gz 8070633 BLAKE2B 3ed83bf57654f89d0b579ec9df64a9025d9fae1da755018c83cfd6ac03e70da176de564185a2ad1f68383ff0c6a2e26132568cb451bc1b474b87c4852dc2266b SHA512 e1fccfafa845b1964f824850c05fa39904e2804f8145f24342ee86e6c9f1a8ffbb30b1a822744343f59ba9dc4b1e4788020d0cc6b954d9f62eeeb43a594bd326
diff --git a/app-containers/earthly/earthly-0.8.14.ebuild b/app-containers/earthly/earthly-0.8.14.ebuild
new file mode 100644
index 000000000000..170592ca9cd4
--- /dev/null
+++ b/app-containers/earthly/earthly-0.8.14.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == "0.8.14" ]] ; then
+ COMMIT_SHA="6b41f8409d7ffef0d25072c2c04250074b6e3c72"
+else
+ die 'Could not detect "COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local -r go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a -r go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o ./bin/
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}