summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/xdvdfs-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/xdvdfs-tools')
-rw-r--r--app-cdr/xdvdfs-tools/Manifest1
-rw-r--r--app-cdr/xdvdfs-tools/files/xdvdfs-tools-2.1-fnamefix.patch17
-rw-r--r--app-cdr/xdvdfs-tools/metadata.xml6
-rw-r--r--app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild46
4 files changed, 70 insertions, 0 deletions
diff --git a/app-cdr/xdvdfs-tools/Manifest b/app-cdr/xdvdfs-tools/Manifest
new file mode 100644
index 000000000000..5b9c58c6df3f
--- /dev/null
+++ b/app-cdr/xdvdfs-tools/Manifest
@@ -0,0 +1 @@
+DIST XDVDFSToolsv2.1.rar 211193 SHA256 ad9603564597004151812302074408a60c54cabcc19e843e1186b5a506eb068f SHA512 c3158dc603ac363cadc2dcc99fd112ef66be6ae8fa4f89544cbf4c5a6490cace82cf1d16fa748ede4d206359e2e6752ffd6bfe074ad3c48f9a829e4938f1e99d WHIRLPOOL 2b746fd49df10d0eb212c6aa91a88abdf2214c56d3eabc496e34ae58faf7aff0a921e72d3a9547b225823792dfdcc45617d78dacfb7d5d21c0b58f21eec441f5
diff --git a/app-cdr/xdvdfs-tools/files/xdvdfs-tools-2.1-fnamefix.patch b/app-cdr/xdvdfs-tools/files/xdvdfs-tools-2.1-fnamefix.patch
new file mode 100644
index 000000000000..4d06822eb06c
--- /dev/null
+++ b/app-cdr/xdvdfs-tools/files/xdvdfs-tools-2.1-fnamefix.patch
@@ -0,0 +1,17 @@
+--- XDVDFS_Tools.orig/src/xdvdfs/xdvdfs.c 2003-08-15 23:26:58.000000000 +0000
++++ XDVDFS_Tools/src/xdvdfs/xdvdfs.c 2005-05-21 12:13:55.655839216 +0000
+@@ -157,6 +157,14 @@
+ memcpy(SearchRecord->Filename, Entry->Filename, Entry->FilenameLength);
+ SearchRecord->Filename[Entry->FilenameLength] = 0;
+
++ if (strstr(SearchRecord->Filename,"..") ||
++ strchr(SearchRecord->Filename, '/') ||
++ strchr(SearchRecord->Filename, '\\'))
++ {
++ printf("Filename contains invalid characters\n");
++ exit(1);
++ }
++
+ // Copy file parameters in the search_rec
+ SearchRecord->Attributes = Entry->FileAttributes;
+ SearchRecord->FileSize = ENDIAN_SAFE32(Entry->FileSize);
diff --git a/app-cdr/xdvdfs-tools/metadata.xml b/app-cdr/xdvdfs-tools/metadata.xml
new file mode 100644
index 000000000000..14dba77325f5
--- /dev/null
+++ b/app-cdr/xdvdfs-tools/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xbox</herd>
+ <longdescription>Tools for manipulating Xbox ISO images</longdescription>
+</pkgmetadata>
diff --git a/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild b/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
new file mode 100644
index 000000000000..6700a32e485d
--- /dev/null
+++ b/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for manipulating Xbox ISO images"
+HOMEPAGE="http://www.layouts.xbox-scene.com/"
+SRC_URI="http://www.layouts.xbox-scene.com/main/files/XDVDFSToolsv${PV}.rar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/unrar app-arch/rar )"
+RDEPEND=""
+
+S=${WORKDIR}/XDVDFS_Tools/src
+
+src_unpack() {
+ unpack ${A}
+ mv "XDVDFS Tools" XDVDFS_Tools
+ sed -i \
+ -e '/^LDFLAGS = -s/d' \
+ -e '/^CCFLAGS =/s:=.*:= ${CFLAGS} ${CPPFLAGS}:g' \
+ -e "/^CC =/s:=.*:=$(tc-getCC):" \
+ "${S}"/makefile.prefab
+ epatch "${FILESDIR}"/${P}-fnamefix.patch
+ mkdir "${S}"/xdvdfs_extract/output "${S}"/xdvdfs_maker/output
+}
+
+src_compile() {
+ local d
+ for d in xdvdfs_{dumper,extract,maker} ; do
+ emake -C ${d} || die
+ done
+}
+
+src_install() {
+ dobin xdvdfs_dumper/output/xdvdfs_dumper || die "xdvdfs_dumper"
+ dobin xdvdfs_extract/output/xdvdfs_extract || die "xdvdfs_extract"
+ dobin xdvdfs_maker/output/xdvdfs_maker || die "xdvdfs_maker"
+ dohtml ../documentation/*.htm
+ dodoc ../Readme.txt
+}