summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-19 23:51:11 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-19 23:51:11 +0100
commitbf30f2f1ba9ac59e9f2502671e37e60205be3aa6 (patch)
tree69117d2f5a5c840a162889f10eca207e65194f22 /app-benchmarks/iozone
parentapp-containers/cosign: drop 1.5.2 (diff)
downloadgentoo-bf30f2f1ba9ac59e9f2502671e37e60205be3aa6.tar.gz
gentoo-bf30f2f1ba9ac59e9f2502671e37e60205be3aa6.tar.bz2
gentoo-bf30f2f1ba9ac59e9f2502671e37e60205be3aa6.zip
app-benchmarks/iozone: drop 3.471, 3.484, 3.487
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-benchmarks/iozone')
-rw-r--r--app-benchmarks/iozone/Manifest3
-rw-r--r--app-benchmarks/iozone/iozone-3.471.ebuild73
-rw-r--r--app-benchmarks/iozone/iozone-3.484.ebuild76
-rw-r--r--app-benchmarks/iozone/iozone-3.487.ebuild76
4 files changed, 0 insertions, 228 deletions
diff --git a/app-benchmarks/iozone/Manifest b/app-benchmarks/iozone/Manifest
index 312115badbdd..6a9a704272d8 100644
--- a/app-benchmarks/iozone/Manifest
+++ b/app-benchmarks/iozone/Manifest
@@ -1,4 +1 @@
-DIST iozone3_471.tar 1853440 BLAKE2B 280c821a439ad1bacbd749278385481678d644a59c14395482c8a088b0578285f389f376fb32ce3c3abde598f50d693fb0c7c9a3d6597765547a71c76d21ea1c SHA512 c61b2b8b5af3dccdb99b26aef8a0a4f2f5f467fc3985ac72ed4bb4fb36e4b7684ca6dbaa5bbc05ae0a4e73852e048e9fd2495eda9313f5abc4e631499d683aec
-DIST iozone3_484.tar 1863680 BLAKE2B 72d3d3125aec2dfc504bb00684ef325e85edffe0d6efcd519cd692cfa2b9b792a44c00313dc96eabbbb3ab850a7a440b3ca3d5b955c4f6092b08f92ebe5c332b SHA512 bb1ac0c1724a5d3c20e90c56c0b4a438b4aa50384cddc76f4b77f2c465f052fd3fae9217b77688a2c6caf5e90611123a97ea0cd8074b3678068a90e6dd7857b7
-DIST iozone3_487.tar 1873920 BLAKE2B f27edb85ebfd19e55dea239a4e5d595a84981c0249ec57148efdcce90a85a5cbf1e17f319de820a06410c66390ddd38efe1b90b31ed98c3bf979eea6fb25ccc7 SHA512 2f3a9d259ca531e45124e8ad55358706e2f9615f50fbf434e786b832622aa5f673dbed1b2706c6450c200e0af7f7374e40402e0b06ad116d5f2a0704a6156a1a
DIST iozone3_488.tar 1873920 BLAKE2B 60e97d588a273c1af7a8c83ec207593fcf43766f92171774b974aa04a8df690a1a84aae4b448e4a6f9e4e9c7dc3cd98ad327a0ea196779e6dbe3a88326314eaf SHA512 033f9e6e7395fe84ae6f4ae8737544e399ac0f16e82ba95eed2a2d0df52b7efcbe0c9282abc68d3c5b53d859073c74bff2e8c34bc35e1e1cc887ed36ad5d840b
diff --git a/app-benchmarks/iozone/iozone-3.471.ebuild b/app-benchmarks/iozone/iozone-3.471.ebuild
deleted file mode 100644
index 247a52b7b3e0..000000000000
--- a/app-benchmarks/iozone/iozone-3.471.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# TODO
-# -> linux-arm (32bit) <-
-# -> linux-AMD64 (64bit) <-
-# -> linux-ia64 (64bit) <-
-# -> linux-powerpc (32bit) <-
-# -> linux-powerpc64 (64bit) <-
-# -> linux-S390 (32bit) <-
-# -> linux-S390X (64bit) <-
-#
-# -> freebsd (32bit) <-
-# -> macosx (32bit) <-
-# -> netbsd (32bit) <-
-# -> openbsd (32bit) <-
-# -> openbsd-threads (32bit) <-
-#
-# ~ia64 ~s390 alpha(?)
-
-inherit toolchain-funcs
-
-DESCRIPTION="Filesystem benchmarking program"
-HOMEPAGE="http://www.iozone.org/"
-SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="amd64 arm ~ia64 ppc ppc64 ~sparc x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}${PV/./_}
-
-src_prepare() {
- default
-
- # Options FIX
- sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
- -e "s:-O3:${CFLAGS}:g" src/current/makefile || die
-}
-
-src_configure() {
- case ${ARCH} in
- x86|alpha) PLATFORM="linux";;
- arm) PLATFORM="linux-arm";;
- ppc) PLATFORM="linux-powerpc";;
- ppc64) PLATFORM="linux-powerpc64";;
- amd64) PLATFORM="linux-AMD64";;
- ia64) PLATFORM="linux-ia64";;
- s390) PLATFORM="linux-S390";;
- *) PLATFORM="linux-${ARCH}";;
- esac
-}
-
-src_compile() {
- emake -C src/current ${PLATFORM}
-}
-
-src_test() {
- cd "${T}" || die
- "${S}"/src/current/iozone testfile || die "self test failed"
-}
-
-src_install() {
- dosbin src/current/{iozone,fileop}
-
- dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
- doman docs/iozone.1
- cd src/current || die
- dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
-}
diff --git a/app-benchmarks/iozone/iozone-3.484.ebuild b/app-benchmarks/iozone/iozone-3.484.ebuild
deleted file mode 100644
index c104e9f4dddc..000000000000
--- a/app-benchmarks/iozone/iozone-3.484.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-# TODO
-# -> linux-arm (32bit) <-
-# -> linux-AMD64 (64bit) <-
-# -> linux-ia64 (64bit) <-
-# -> linux-powerpc (32bit) <-
-# -> linux-powerpc64 (64bit) <-
-# -> linux-S390 (32bit) <-
-# -> linux-S390X (64bit) <-
-#
-# -> freebsd (32bit) <-
-# -> macosx (32bit) <-
-# -> netbsd (32bit) <-
-# -> openbsd (32bit) <-
-# -> openbsd-threads (32bit) <-
-#
-# ~ia64 ~s390 alpha(?)
-
-inherit toolchain-funcs
-
-DESCRIPTION="Filesystem benchmarking program"
-HOMEPAGE="http://www.iozone.org/"
-SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}${PV/./_}
-
-src_prepare() {
- default
-
- # Options FIX
- sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
- -e "s:-O3:${CFLAGS}:g" src/current/makefile || die
-}
-
-src_configure() {
- case ${ARCH} in
- x86|alpha) PLATFORM="linux";;
- arm) PLATFORM="linux-arm";;
- ppc) PLATFORM="linux-powerpc";;
- ppc64) PLATFORM="linux-powerpc64";;
- amd64) PLATFORM="linux-AMD64";;
- ia64) PLATFORM="linux-ia64";;
- s390) PLATFORM="linux-S390";;
- *) PLATFORM="linux-${ARCH}";;
- esac
-}
-
-src_compile() {
- emake -C src/current ${PLATFORM}
-}
-
-src_test() {
- cd "${T}" || die
- "${S}"/src/current/iozone testfile || die "self test failed"
-}
-
-src_install() {
- dosbin src/current/{iozone,fileop}
-
- # decompress pre-compressed file to make QA check happy
- gzip -d docs/Iozone_ps.gz || die
-
- dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
- doman docs/iozone.1
- cd src/current || die
- dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
-}
diff --git a/app-benchmarks/iozone/iozone-3.487.ebuild b/app-benchmarks/iozone/iozone-3.487.ebuild
deleted file mode 100644
index c104e9f4dddc..000000000000
--- a/app-benchmarks/iozone/iozone-3.487.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-# TODO
-# -> linux-arm (32bit) <-
-# -> linux-AMD64 (64bit) <-
-# -> linux-ia64 (64bit) <-
-# -> linux-powerpc (32bit) <-
-# -> linux-powerpc64 (64bit) <-
-# -> linux-S390 (32bit) <-
-# -> linux-S390X (64bit) <-
-#
-# -> freebsd (32bit) <-
-# -> macosx (32bit) <-
-# -> netbsd (32bit) <-
-# -> openbsd (32bit) <-
-# -> openbsd-threads (32bit) <-
-#
-# ~ia64 ~s390 alpha(?)
-
-inherit toolchain-funcs
-
-DESCRIPTION="Filesystem benchmarking program"
-HOMEPAGE="http://www.iozone.org/"
-SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}${PV/./_}
-
-src_prepare() {
- default
-
- # Options FIX
- sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
- -e "s:-O3:${CFLAGS}:g" src/current/makefile || die
-}
-
-src_configure() {
- case ${ARCH} in
- x86|alpha) PLATFORM="linux";;
- arm) PLATFORM="linux-arm";;
- ppc) PLATFORM="linux-powerpc";;
- ppc64) PLATFORM="linux-powerpc64";;
- amd64) PLATFORM="linux-AMD64";;
- ia64) PLATFORM="linux-ia64";;
- s390) PLATFORM="linux-S390";;
- *) PLATFORM="linux-${ARCH}";;
- esac
-}
-
-src_compile() {
- emake -C src/current ${PLATFORM}
-}
-
-src_test() {
- cd "${T}" || die
- "${S}"/src/current/iozone testfile || die "self test failed"
-}
-
-src_install() {
- dosbin src/current/{iozone,fileop}
-
- # decompress pre-compressed file to make QA check happy
- gzip -d docs/Iozone_ps.gz || die
-
- dodoc docs/I* docs/Run_rules.doc src/current/Changes.txt
- doman docs/iozone.1
- cd src/current || die
- dodoc Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
-}