summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-02 11:07:45 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:43:23 +0200
commitb7e1208ee7e38f581ea79dbf2195e987d940b447 (patch)
tree3c523fd1f65717004afc29757e56562327bb8e11 /app-arch
parentapp-admin/sxid: add 4.20130802 (diff)
downloadgentoo-b7e1208ee7e38f581ea79dbf2195e987d940b447.tar.gz
gentoo-b7e1208ee7e38f581ea79dbf2195e987d940b447.tar.bz2
gentoo-b7e1208ee7e38f581ea79dbf2195e987d940b447.zip
app-arch/afio: add 2.5.2
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/708486 Closes: https://github.com/gentoo/gentoo/pull/36966 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/afio/Manifest1
-rw-r--r--app-arch/afio/afio-2.5.2.ebuild35
-rw-r--r--app-arch/afio/files/afio-2.5.2-fix-build-system.patch26
3 files changed, 62 insertions, 0 deletions
diff --git a/app-arch/afio/Manifest b/app-arch/afio/Manifest
index 679a988d1be2..ae4520a84f3d 100644
--- a/app-arch/afio/Manifest
+++ b/app-arch/afio/Manifest
@@ -1 +1,2 @@
DIST afio-2.5.1.tgz 191765 BLAKE2B 48a590c1180942444eb8fc17701563ee822cad9d0ae423e12996e7b3dff16ab7ba13d8041b78fb6415d1a422d14be8ba3443910ae1a57290dca801334ced7ffe SHA512 afa4e01cc9e7da5bff7c96d2da9a41c296e7b89c50484f58a8b011173a99a144a9e77d3ee8136622e490287b99a7ae76c6eba901a2186b5a3a6bab164a37c864
+DIST afio-2.5.2.tar.gz 194030 BLAKE2B 7c46162cf8648b9b6c32003032a820a847e4887bb852a49ee878dc3501bad673650f7b64c465c4cea58b4cfd4de74884f903211f298ef94b91d3738f7de29316 SHA512 e0fb9b2d31bb912d7f30d8dd992cffcc99a84424c7386082abb8da82a1911b852c5a80e8135f0b6266113519f582dba45dc3c87c8f3b822a2daa14a1ae1d9944
diff --git a/app-arch/afio/afio-2.5.2.ebuild b/app-arch/afio/afio-2.5.2.ebuild
new file mode 100644
index 000000000000..d646d4a7b503
--- /dev/null
+++ b/app-arch/afio/afio-2.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="CPIO-Archiver & backup program with fault tolerant compression"
+HOMEPAGE="https://github.com/kholtman/afio"
+SRC_URI="https://github.com/kholtman/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
+ done
+}
diff --git a/app-arch/afio/files/afio-2.5.2-fix-build-system.patch b/app-arch/afio/files/afio-2.5.2-fix-build-system.patch
new file mode 100644
index 000000000000..5f5f113e0df9
--- /dev/null
+++ b/app-arch/afio/files/afio-2.5.2-fix-build-system.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -74,19 +74,14 @@
+ #code can be reviewed manually
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer -Wno-unused-result $(LARGEFILEFLAGS) $(MW)
+-
+-CC=gcc
+-
+ # also using contents of usin CPPFLAGS, CFLAGS, LDFLAGS out of environment
+ # variables, if they exist
+-CFLAGS += $(CFLAGS1) $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e $(e2) $f $g $I
+-LDFLAGS +=
+-CPPFLAGS +=
++CC ?= gcc
++CFLAGS += -Wall -Wstrict-prototypes
++CPPFLAGS += ${LARGEFILEFLAGS} ${2} ${3} ${6} ${8} ${c} ${d} ${e2} ${f} ${g}
+
+ afio : afio.o compfile.o exten.o match.o $M
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) \
+- afio.o compfile.o exten.o match.o $M -o afio
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ clean:
+ rm -f *.o afio