summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/stuffit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/stuffit')
-rw-r--r--app-arch/stuffit/Manifest1
-rw-r--r--app-arch/stuffit/metadata.xml8
-rw-r--r--app-arch/stuffit/stuffit-5.2.0.611.ebuild66
3 files changed, 75 insertions, 0 deletions
diff --git a/app-arch/stuffit/Manifest b/app-arch/stuffit/Manifest
new file mode 100644
index 000000000000..d8418bf5595f
--- /dev/null
+++ b/app-arch/stuffit/Manifest
@@ -0,0 +1 @@
+DIST stuffit520.611linux-i386.tar.gz 1955619 SHA256 69ccd8659000f7cdeba640157ed42e360b2e448c8e8333b1db491f2c4daf7998 SHA512 a1d4631c2d238b49c710816cd5ed8a01dcf52c29b870297b8dfd76fb0cb6e725c5b0f9d4a6c155c7b6980005df52fc4597632f72e90f00bf93ad80a28972270a WHIRLPOOL 438a33133d959879d81cca96a2659b82ae07c3cd4b137904f3e02fbbedac6a183ba411ab4e864e3bfa0bee2b27531bfbbaab7928d138640069e01bbc605669cb
diff --git a/app-arch/stuffit/metadata.xml b/app-arch/stuffit/metadata.xml
new file mode 100644
index 000000000000..676bee02ece4
--- /dev/null
+++ b/app-arch/stuffit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>Stuffit is a archive creating application, supporting .sit, .sitx .zip, and self-extracting archives</longdescription>
+</pkgmetadata>
diff --git a/app-arch/stuffit/stuffit-5.2.0.611.ebuild b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
new file mode 100644
index 000000000000..1a5ad6d1547e
--- /dev/null
+++ b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="stuffit520.611linux-i386"
+DESCRIPTION="Aladdin Software's StuffIt and StuffIt Expander"
+HOMEPAGE="http://www.stuffit.com/"
+SRC_URI="http://my.smithmicro.com/downloads/files/stuffit520.611linux-i386.tar.gz"
+
+LICENSE="Stuffit"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE=""
+RESTRICT="fetch strip"
+
+S="${WORKDIR}"
+
+INSTALLDIR="/opt/stuffit"
+
+pkg_nofetch() {
+ einfo "Please download stuffit from"
+ einfo "${SRC_URI}"
+ einfo "and put the file in ${DISTDIR}"
+ einfo
+ einfo "Note that StuffIt requires registration within 30 days,"
+ einfo "but StuffIt Expander is freeware."
+ einfo
+}
+
+src_install() {
+
+ # First do the binaries
+ exeinto ${INSTALLDIR}/bin
+ doexe bin/stuff
+ doexe bin/unstuff
+
+ # Now the registration binary
+ exeinto ${INSTALLDIR}/extra
+ doexe bin/register
+
+ # Now the documentation
+ docinto stuff
+ dodoc doc/stuff/README
+ dohtml doc/stuff/stuff.html
+ docinto unstuff
+ dodoc doc/unstuff/README
+ dohtml doc/unstuff/unstuff.html
+
+ # And now the man pages
+ doman man/man1/*
+
+ # Also add the executables to the path
+ dodir /etc/env.d
+ echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}/bin" > \
+ "${D}"/etc/env.d/10stuffit
+
+}
+
+pkg_postinst() {
+ elog
+ elog "Reminder: StuffIt requires registration within 30 days."
+ elog "The registration program is located in ${INSTALLDIR}/extra"
+ elog
+ elog "The binaries are named 'stuff' and 'unstuff'"
+ elog
+}