summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-05-09 12:27:16 -0500
committerBen Kohler <bkohler@gentoo.org>2023-05-10 13:02:45 -0500
commit01d9b43c3b3868b18af6dbef1a0ed3ff9fcad0a5 (patch)
tree142ad4d44314a47f9b6532e4fd1c0d8716812450 /app-admin/ps_mem
parentnet-misc/dropbox: drop 171.4.6182, 172.4.7555 (diff)
downloadgentoo-01d9b43c3b3868b18af6dbef1a0ed3ff9fcad0a5.tar.gz
gentoo-01d9b43c3b3868b18af6dbef1a0ed3ff9fcad0a5.tar.bz2
gentoo-01d9b43c3b3868b18af6dbef1a0ed3ff9fcad0a5.zip
app-admin/ps_mem: update EAPI 7 -> 8
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-admin/ps_mem')
-rw-r--r--app-admin/ps_mem/ps_mem-3.14-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.14-r1.ebuild b/app-admin/ps_mem/ps_mem-3.14-r1.ebuild
new file mode 100644
index 000000000000..118fbba1a322
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.14-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/ps_mem"
+SRC_URI="https://github.com/pixelb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}