summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-08 13:37:21 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-08 13:37:21 +0100
commitb1b6e4a46931c0998199aae07b6b3cc73db730b2 (patch)
tree2a05abf709ee09d4809a29b2431ff5833a5798d4 /app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
parentsys-devel/bison: Removed old (diff)
downloadgentoo-b1b6e4a46931c0998199aae07b6b3cc73db730b2.tar.gz
gentoo-b1b6e4a46931c0998199aae07b6b3cc73db730b2.tar.bz2
gentoo-b1b6e4a46931c0998199aae07b6b3cc73db730b2.zip
app-admin/procinfo-ng: Port to EAPI 7
* Use CXXFLAGS instead of CFLAGS for .cpp files * Use proper Autoconf macros for ncurses * Unify patches Closes: https://bugs.gentoo.org/668660 Closes: https://github.com/gentoo/gentoo/pull/14635 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Suggested-by: Denis Pronin <dannftk@yandex.ru> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild')
-rw-r--r--app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild25
1 files changed, 8 insertions, 17 deletions
diff --git a/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
index 791cfbd4c7fb..49ce7d2cac57 100644
--- a/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
+++ b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils toolchain-funcs
+inherit autotools
DESCRIPTION="Completely rewrite of the old system monitoring app procinfo"
HOMEPAGE="https://sourceforge.net/projects/procinfo-ng/"
@@ -12,29 +12,20 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="|| ( GPL-2 LGPL-2.1 )"
SLOT="0"
KEYWORDS="amd64 hppa x86"
-IUSE=""
RDEPEND="
sys-libs/ncurses:0=
!app-admin/procinfo"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-autotools.patch
"${FILESDIR}"/${P}-man.patch
)
src_prepare() {
- epatch "${PATCHES[@]}"
- # removing -s flag as portage does the stripping part and add support
- # for custom LDFLAGS. Plus correct for --as-needed
- sed \
- -e 's:-s -lncurses:${LDFLAGS}:' \
- -i configure.in || die "sed configure.in failed"
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
-
-src_compile() {
- emake LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
-}