summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Heule <nerve@ipwar.ch>2019-10-05 15:52:36 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-10 16:56:55 +0300
commitd7d6f497e8f423dcb1fafd212a3d95a4e93106bb (patch)
tree7a6fba5c1f6f02320b392e89d81319800a9508cc /app-admin/cdist
parentnet-print/cups-filters: Bump to version 1.25.11 (diff)
downloadgentoo-d7d6f497e8f423dcb1fafd212a3d95a4e93106bb.tar.gz
gentoo-d7d6f497e8f423dcb1fafd212a3d95a4e93106bb.tar.bz2
gentoo-d7d6f497e8f423dcb1fafd212a3d95a4e93106bb.zip
app-admin/cdist: bump to 6.0.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Daniel Heule <nerve@ipwar.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-6.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index a175f718e1a1..c082d2be2989 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,2 +1,3 @@
DIST cdist-4.10.6.tar.gz 676651 BLAKE2B 107b60c8890ede0bfa9f741375cc1705946b2d6be9caa4ae41c2ba155097b64e451474218ae9d5a8e2aa2511908869e8a5aa24fe15f0d41a50c8775d037a7eb3 SHA512 558fbe242a24fcd204a0b2519c9ad73405fe20466600af3635c6a5029641c4aec4315be99af0d5d9c1920aaadfe96942ffab94133c48675655ea8107fc8af90c
DIST cdist-5.1.3.tar.gz 915245 BLAKE2B 5fce58f6fcbd48852e1c0c5568b72c360e74fd49b5321e2aedfdc8e48fd090cbdd7bab87a94e76d087f04f5a706bf2c7b1bebdc5a80867e26d8cc6e28afdeab3 SHA512 8330a5af80dfc07da722675ae1d402ebae4ba0aada451a02d782365d68d1d43a643609f3326f5ed793d2902838ee29071c0255c9d8a9d38c1e8a7c92a24cef46
+DIST cdist-6.0.0.tar.gz 934813 BLAKE2B 3cb18ebb3059fc9a37beb1567c691e1d34a9cde5d49081e8798b5ba86ea8da3b6c964d2c8bea7bf2f04f986b0b4a8766c8ea53ce48fb4bc024264e72efec1fcb SHA512 e846060f3020d6281d41e97b9cc33250cd1d4ae0d110a2792fc2447af110fef91199fc0382d5a1e501f487fda42f703957ff5a39cf28061338609a600290d792
diff --git a/app-admin/cdist/cdist-6.0.0.ebuild b/app-admin/cdist/cdist-6.0.0.ebuild
new file mode 100644
index 000000000000..7a9ce8da65df
--- /dev/null
+++ b/app-admin/cdist/cdist-6.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}