summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 22:16:54 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:47 -0500
commitfb20c1f02ffe014b60bd6068c7de44d755915278 (patch)
tree9f6e0f7761f5f685616ef82c4977b73bc6f73590 /app-accessibility
parentapp-crypt/seahorse: Version bump to 3.38.1 (diff)
downloadgentoo-fb20c1f02ffe014b60bd6068c7de44d755915278.tar.gz
gentoo-fb20c1f02ffe014b60bd6068c7de44d755915278.tar.bz2
gentoo-fb20c1f02ffe014b60bd6068c7de44d755915278.zip
app-accessibility/accerciser: Version bump to 3.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/Manifest1
-rw-r--r--app-accessibility/accerciser/accerciser-3.38.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
index 9388c6185a69..4025006fe2ce 100644
--- a/app-accessibility/accerciser/Manifest
+++ b/app-accessibility/accerciser/Manifest
@@ -1 +1,2 @@
DIST accerciser-3.36.2.tar.xz 1995756 BLAKE2B 14d569f159cda685bb5217cb650d64c473c296e6c0e74bf2d6290908ea4aef06fd736aa8bdb7782a7bbd5231895a53e85fa362382fd15cf0554721fe46c8cbe9 SHA512 fb2ecb35826f1a868a8badcefcb4941258273bfc639996b8d4cecbd5d9700cb48e102891105842fcf3b0cb5f7a53df28de3283a80130d83695528db06ff0f268
+DIST accerciser-3.38.0.tar.xz 2006380 BLAKE2B 8a073e3a933386c9ae46d71535a3a49930bf8100d1458ac1875e1bcb69acc13e2331ac568c566ec6b8fe8ff9836155cc2ff20558de0e21942a29a568ff916fa5 SHA512 5740e4acfb00f5842dac8045ca9f10c85cf2ae164f3e0caf63ec303ff104002ace6de591a9b6516c4052ec0da8e48b394647f018b6c8b68a6c5ff77c4fff2904
diff --git a/app-accessibility/accerciser/accerciser-3.38.0.ebuild b/app-accessibility/accerciser/accerciser-3.38.0.ebuild
new file mode 100644
index 000000000000..bdad92ae536b
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.38.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ ')
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ gnome-base/librsvg[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}