summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-03-25 13:59:03 -0500
committerBen Kohler <bkohler@gentoo.org>2021-03-25 14:03:46 -0500
commitad7f65ff32154b1ea6cd2e350c788997e8381c80 (patch)
treee2c2c33b6a57d1afa5e008885d83888a7a812e24
parentgames-board/ace: fix build with slibtool (diff)
downloadgentoo-ad7f65ff32154b1ea6cd2e350c788997e8381c80.tar.gz
gentoo-ad7f65ff32154b1ea6cd2e350c788997e8381c80.tar.bz2
gentoo-ad7f65ff32154b1ea6cd2e350c788997e8381c80.zip
net-libs/libssh2: slot operator dep on mbedtls
Closes: https://bugs.gentoo.org/717696 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-libs/libssh2/libssh2-1.9.0_p20200614-r1.ebuild (renamed from net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild)4
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild b/net-libs/libssh2/libssh2-1.9.0_p20200614-r1.ebuild
index edff9820da9c..3e48a3afea49 100644
--- a/net-libs/libssh2/libssh2-1.9.0_p20200614.ebuild
+++ b/net-libs/libssh2/libssh2-1.9.0_p20200614-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,7 +21,7 @@ RESTRICT="test"
RDEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
!gcrypt? (
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:0=[${MULTILIB_USEDEP}] )
!mbedtls? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index ecb95eb5807f..9144d2576661 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ RESTRICT="test"
RDEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
!gcrypt? (
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:0=[${MULTILIB_USEDEP}] )
!mbedtls? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )