summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:37:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:27 +0100
commit9ed3eee5e30436ff162fe28b3162f2d661c6bb4d (patch)
treeb1187ad2e25aa32d8f7665230f1bbf1480da5f1e
parentdev-python/pylint: Bump to 2.17.1 (diff)
downloadgentoo-9ed3eee5e30436ff162fe28b3162f2d661c6bb4d.tar.gz
gentoo-9ed3eee5e30436ff162fe28b3162f2d661c6bb4d.tar.bz2
gentoo-9ed3eee5e30436ff162fe28b3162f2d661c6bb4d.zip
dev-python/pyproject-fmt: Bump to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index dfa0a7af21d9..8c253b7cba87 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1 +1,2 @@
DIST pyproject-fmt-0.9.1.gh.tar.gz 15434 BLAKE2B f9dd55b4106e875c80127ac60b3a54d4bdadf3555266a74cfd811ab96500879a7efb8eac71a041b2c33486bfcbc1f818a26a3ae3c50685f35cc3712691a85bb9 SHA512 ade87f43927c74e0328ffa8ac542bad204cc283d694f6921c40c86ae0a941ae50cc43fa4078ddcec28ff0d6003ac34a54232ea23d2820b5b2582482b22ac2a7e
+DIST pyproject-fmt-0.9.2.gh.tar.gz 15615 BLAKE2B 91912d350224fb2cbfd5f4e2310c10849dd0a1f43ac076059b521966d07526f9509cf87bba182cc4e9eb6b87c7c58c2972bb4f256bf63724e9d3b6c4fe9e67dd SHA512 3045381fc811fa8b8b7e845d9af5564d1969b73bfbb3e5a5c1953843754607cdbd809b829691d7195df73a1e136f68fbb3d3b66c783aa7c706b352e88d9b3f92
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild
new file mode 100644
index 000000000000..a802c14c305f
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}