summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-13 20:40:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-13 20:41:31 +0300
commit8df5f88e64001dfc3a9da37d9d9ab7ce72bb6717 (patch)
treeb92e63c6b91e20c508c8d398c3b2d92ecc06b673
parentapp-containers/incus: add/fix apparmor & qemu support (diff)
downloadgentoo-8df5f88e64001dfc3a9da37d9d9ab7ce72bb6717.tar.gz
gentoo-8df5f88e64001dfc3a9da37d9d9ab7ce72bb6717.tar.bz2
gentoo-8df5f88e64001dfc3a9da37d9d9ab7ce72bb6717.zip
dev-python/tree-sitter: depend on setuptools for py3.12
Import distutils module on every load of the library, and works well with setuptools "internal" distutils. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/tree-sitter/tree-sitter-0.20.1-r1.ebuild (renamed from dev-python/tree-sitter/tree-sitter-0.20.1.ebuild)8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/tree-sitter/tree-sitter-0.20.1.ebuild b/dev-python/tree-sitter/tree-sitter-0.20.1-r1.ebuild
index 8388598b62b2..f7fa52853dbd 100644
--- a/dev-python/tree-sitter/tree-sitter-0.20.1.ebuild
+++ b/dev-python/tree-sitter/tree-sitter-0.20.1-r1.ebuild
@@ -32,8 +32,12 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-RDEPEND="dev-libs/tree-sitter:="
-DEPEND="${RDEPEND}"
+DEPEND="dev-libs/tree-sitter:="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' 3.12)
+"
distutils_enable_tests unittest